Website Youtube GitHub

mGear Framework Forum

Mgear 3.6.0 maya 2019.3 linux

I have problem in specified configuration.

After creating guide build process is not completed it stops with message:
= BUILDING RIG ==============================================
Initial Hierarchy
# Traceback (most recent call last):
#   File "/home/mirkoj/maya/modules/scripts/mgear/shifter/guide_manager.py", line 62, in build_from_selection
#     rg.buildFromSelection()
#   File "/home/mirkoj/maya/modules/scripts/mgear/shifter/__init__.py", line 192, in buildFromSelection
#     self.build()
#   File "/home/mirkoj/maya/modules/scripts/mgear/shifter/__init__.py", line 217, in build
#     self.initialHierarchy()
#   File "/home/mirkoj/maya/modules/scripts/mgear/shifter/__init__.py", line 338, in initialHierarchy
#     "circle", w=10)
#   File "/home/mirkoj/maya/modules/scripts/mgear/shifter/__init__.py", line 505, in addCtl
#     self.add_controller_tag(ctl, None)
#   File "/home/mirkoj/maya/modules/scripts/mgear/shifter/__init__.py", line 558, in add_controller_tag
#     self.model.attr("rigCtlTags[{}]".format(str(ni))))
#   File "/usr/autodesk/maya2019/lib/python2.7/site-packages/pymel/core/nodetypes.py", line 2003, in attr
#     res = self._attr(attr, checkShape)
#   File "/usr/autodesk/maya2019/lib/python2.7/site-packages/pymel/core/nodetypes.py", line 504, in _attr
#     nameTokens = nameparse.getBasicPartList('dummy.' + attr)
#   File "/usr/autodesk/maya2019/lib/python2.7/site-packages/pymel/util/nameparse.py", line 1541, in getBasicPartList
#     getParts(MayaObjectName(name))
#   File "/usr/autodesk/maya2019/lib/python2.7/site-packages/pymel/util/objectParser.py", line 374, in __new__
#     result = newcls.classparse(value, debug=debug)
#   File "/usr/autodesk/maya2019/lib/python2.7/site-packages/pymel/util/objectParser.py", line 148, in classparse
#     result = cls.classparser().parse(data, debug=debug)
#   File "/usr/autodesk/maya2019/lib/python2.7/site-packages/pymel/util/objectParser.py", line 593, in parse
#     return self.parser.parse(data, lexer=self.lexer, **kwargs)
# AttributeError: 'NoneType' object has no attribute 'parse'

Works fine under windows. Tried in clear guide as well just import guide and build. |
Any ideas?

Hi, mirkoj. Does this happens only with specified guides you have or it happens to all guides?

all, even if I just import sample guide and try to build right away, no editing at all. Works fine in maya but on my linux machine, no luck

I’m on Linux machine. I’ll check it later.

Just installed version 3.6 and In my case it works fine. I’m on Centos 7.8 . It looks like PyMel Attribute error and the Shifter stops working after this line :
self.model.attr("rigCtlTags[{}]".format(str(ni))))
Can you check it with some print command? Without having that problem is quite difficult to find the it.

no tsure how exactly to check?
I’m on Pop OS, that is ubuntu based.

It seems like a fairly generic thing going wrong here. The final error seems to mean that newcls.classparser() is showing up as None instead of as a class. That could be a Linux PyMEL bug, or possibly mGear.

  1. First, have you tried with fresh preferences just to eliminate any strange bugs in your setup? (back up your preferences first.)
  2. Right after you get the error, what happens if you try running this code? If your rig’s top group is not called “rig”, make sure to change it.
import pymel.core as pm

model = pm.PyNode('rig')
print(model.attr("rigCtlTags[0]"))
print(model.attr("rigCtlTags[0]").get())

You should get a result like this in your script output. Or more precisely, you might get an error, and that might hint at what the problem is.

rig.rigCtlTags[0]
world_ctl_tag
1 Like

@mirkoj, as you say your distro is Pop! In order to install Maya on this distro you need to convert RPMs to DEB. Maybe you could try to reinstall you Maya with fresh converted Deb?
Officially Autodesk only supports RHEL/Centos.
My suggestion will be to use Centos 7 instead of Deb based distros.

1 Like