Home Website Youtube GitHub

Rotate problems with Animation Layers

Hi Friends,
I have a problem with Mgear when I use animation layers: it is no longer possible to rotate some guides, such as “spine_C0_ik0_ctl” and “body_C0_ctl”. Any ideas to solve this problem?
I have set up a biped rig using the biped template from shifter and I use mGear 3.7.11, in Win 10 and Maya 2020.4 (same problem in Maya 2022).
Any ideas to solve this problem?
Thank you

Hi Gianmarco,

Is this something you can recreate every time? When you add anim layers, it happens every time?

I saw something similar a few weeks ago. I don’t think the animator was using animation layers. But for some reason, rotation just got frozen in place. He couldn’t scrub attributes in the channel box. Editing curves in the graph editor worked, but the controller wouldn’t rotate or update.

I have a feeling this might be a GPU override bug, or maybe an animation cache bug.

  • Can you try turning off GPU Override. Does it help?
  • If not, try restarting Maya after GPU Override is turned off. Does that help?
  • If not, try turning off Cached Playback if you have it turned on. Does that help?
  • Do you use proxy attributes in your rigs? I remember there were some bugs with animation layers. But I thought those bugs were fixed in 2019 or something…

If none of that helps, can you please provide more information? Maybe a short video screencast of what you mean by “no longer possible to rotate”.

1 Like

I have the same problem on a rig when I add an animation layer I can’t rotate the rig controls.
If I swap out of parrallel mode to DG mode it comes back and allows me to rotate. I can
even swap back to parrallel mode gpu override and it will still work, but if I add another animlayer
it won’t allow me to rotate any of the ctrls in the Anim layers again

Hi Gianmarco,

There is already a thread where a similar problem was discussed.

1 Like

good evening friends,
sorry for the late reply but i have been very busy at work (i use mgear at home as a hobby).
I solved the problem with the tips of the linked discussion:

I unchecked Manipulation in Evaluation Toolkit and now all OK.
Thank you very much to all


1 Like

PS: same problem and same solution on Maya 2022.