Home Website Youtube GitHub

Arm IK/FK match doesn't work if i turn off 'IK separated Trans and Rot ctrl' in the component setting

Hey everyone,

So i have an issue. I don’t want the Translation and Rotation to be separated on my IK arm control.

But when I build the rig that way, the FK/IK automating matching doesn’t work.

It says :
Can’t find object : arm_L0_ikRot_ctl
Can’t find object : arm_L0_ikRot_ctl
AttributeError("‘NoneType’ object has no attribute ‘hasAttr’",)

Is there a solution to this? Do i always have to have IK separated Trans and Rot ctl enabled for me to be able to match FK and IK?

Problem resolved. I replaced the name of the rotate control with the control I had.