Home Website Youtube GitHub

Bake Spring Nodes Help 'Object 0 not found'

Hi guys!

Having some issues trying to bake the dynamics on a chain_spring_01 component

keep getting an ‘Object ‘0’ not found’ error

am using Maya 2022, mgear 4.0.9

tried using the ‘bake springs’ options both in the Synoptic and in the Rigbits>Bake Spring nodes options and both give the same error

Am I missing something here?

Thanks for any help!

Error when using the Rigbits ‘Bake Spring nodes’ menu option:

Error: RuntimeError: file C:\Users*\Documents\maya\2022\modules\scripts\mgear\core\utils.py line 185: paneLayout: Object ‘0’ not found. #

Error when using the synoptic ‘bake springs’ option:

Traceback (most recent call last):
File “C:\Users*\Documents\maya\2022\modules\scripts\mgear\synoptic\widgets.py”, line 64, in mousePressEvent
File “C:\Users*\Documents\maya\2022\modules\scripts\mgear\core\utils.py”, line 214, in wrap
raise e
File “C:\Users*\Documents\maya\2022\modules\scripts\mgear\core\utils.py”, line 211, in wrap
return func(*args, **kwargs)
File “C:\Users*\Documents\maya\2022\modules\scripts\mgear\core\utils.py”, line 185, in wrap
cmds.paneLayout(gMainPane, edit=True, manage=False)
RuntimeError: paneLayout: Object ‘0’ not found.

The synoptic is obsolete, and no longer supported. So I guess it’s not surprising there are problems with it.

For Rigbits, I guess this is a new bug. I haven’t personally tested it yet.

In the meantime, you might have to do it manually. Select the joints that are driven by the spring. Make them keyable. Bake them manually. (Or write a Python script to do so.)

1 Like

Just today I tested the bake springs and it worked. I have several chain_spring components in my rig. Make sure the channel host for the spring chain doesn’t have keys on the chainSpring_spring_intensity attribute. When it’s set to 1, and with the rig top node selected, go to mGear->rigbits->Bake Springs.
Then to see the baked results turn the chainSpring_spring_intensity to 0.

I was getting wacky results if I had any keys on the chainSpring_spring_intensity.

1 Like

Thanks Chris! Looks like baking worked well to capture the dynamics, just a note had to bake the locators above the dynamic joints and not the joints themselves.
Thank you!

Thanks Alonza, there’s no keys on the intensity attribute, so not sure what’s happening there

Did a little test and looks like the rigbits baking works on a simple spring chain rig in maya 2018, so not sure why 2022 isn’t working.
Thought maybe it was a pymel thing, but after updating/reinstalling am still getting the same issue.

Thanks for the help guys!

Personally, I would bake my skin joints directly, not the rig joints. But glad it worked!

1 Like