Home Youtube GitHub

Build Issues - "Get parenting for..."


#1

Hi there!

I’ve been following along with the mGear Data Centric Rigging workshop on character rigging.

The “Build from Selection” feature for some reason appears to be going in loops. It outputs the same lines over and over with occasional interruptions.

Everything was great until I added a few new components and then this started happening. Eventually the rig does get built, but may take minutes versus only a few seconds.

I’ve tried to delete the new guides that I made since my last save, but I haven’t been able to get back to how it was before it started freaking out like this. Any ideas on what’s going on?


#2

No clue, but since you deleted the things you added, and it is still happening, I’ll just ask. Did you also try to restart Maya to see if reloading the mGear modules fixes it?


#3

@davidbk
indeed it is strange. If doesn’t fix after trying re-start like @chrislesage suggested. can you share the guide?


#4

Ah, ok! I see what is causing the problem…

I wanted to do a test build for only the arm. I noticed that when I select only the ‘shoulder_L0_root’ object and go ‘Build From Selection’ that it didn’t include the full hierarchy in the build (arm, meta, metaMid, finger, armUI), it only included the shoulder.

So, then I thought ok, maybe I need to select the full hierarchy in order to build, so I did Select Hierarchy from the shoulder guide and went ‘Build From Selection’. That’s where it started going in loops and taking forever to build.

Then I tried to build by selecting the individual guides one-by-one and it worked.

My question…

Is there a way to build the rig from a selection and include all child guides without having to select them manually?


#5

You need to select it manually or select the top node to build all.

This was a design decision. Indeed is just a simple flag buried in the code. Maybe one day I can expose it as an option.