Website Youtube GitHub

Can't get mgear to build properly anymore


#1

Anyone has a resolve for this. could it be conflicting with something else? It was working fine before. I tried clearing the deleting the prefs to no avail.


#2

can you post the log error? thanks


#3

How do I find it? BTW I’m using 2019.2. It builds ok in 2018.


#4

Right beside the red warning, to the right side, is the button that opens the script editor. You find the errors there.


#5

Another thing to check right away. Did you install mGear by changing your Maya.env file? If so, you need to make sure you add the same lines from Maya 2018 to Maya 2019.

Lines that look like this (you have to use your own paths. Don’t copy these ones.):

MAYA_MODULE_PATH = P:\YourStudio\rigging\tools\mgear_3.0.3
MGEAR_SHIFTER_COMPONENT_PATH = P:\YourStudio\rigging\tools\mgearCustomModules
MGEAR_SHIFTER_CUSTOMSTEP_PATH = P:\YourStudio\rigging\build

mGear uses those paths to find custom modules, or the PRE and POST scripts.


#6

I only have the MAYA_MODULE_PATH


#7

That’s fine. Is it the same in both Maya 2018 and 2019?


#8

Yes. Like I said, everything was working fine. it’s only recently it started bugging.


#9

This is all I’m getting in the script editor:

Error: IOError: file C:\Users\jodana\Documents\maya\scripts\mgear_3.2.0\scripts\mgear_init_.py line 121: 9


#10

What? Yes. that is why I am asking you to make sure that they are the same. If something works in one and not the other, then something has changed… The job right now is to figure out what.

And are you sure that is the only error you are getting? Are you copying from the little status bar, or the full script editor? There must be more than just one line.


#11

I’m copying from the full editor.


#12

The screenshot you showed has part of a rig built. Nothing else showed up in the script editor while it was building?? If you aren’t seeing a full log of the build, then there might be some bug with logging.

Line 121 of that file in the error has to do with the log function.


#13

No, nothing showed. It just stays blank then the error pops up after build. There are no joints building also.


#14

Well, what more info can you give? There is not much to go on here.

Can you post a screenshot of the script editor? And of your guide settings, and PRE POST steps.

Can you think of anything you changed or moved or renamed before it stopped working?


#15

Deleting the maya>2019 folder seems to have fixed it. That is usually my resolve after I getting fed up lol.