Home Website Youtube GitHub

Chain spring baking broken in latest release?

Hiya, I noticed that the rigbits bake spring node gives the error
mgear\core\utils.py line 214: Couldn’t find root node from your selection
so i made a simple control and chain spring and built the rig, and it seems the rigbits>bake spring nodes
gives the same error, this is happening to a co worker as well, just wondering has something changed in the latest mgear that might be causing this ?
if i just throw down a biped or quadruped guide template and attach a chain spring to it and try to use rigbits>bake, in the latest mgear (4.0.3) i get this error, can anyone else confirm ?

thanks
Andrew

wow, im stumped, i just uninstalled 4 and reinstalled 3.7.9
made a fresh rig, added a spring node- build it…
select rigbits > bake springs and get the same error… but, I’ve built rigs with this version that had springs and they worked fine… also, a previously build rig from a month or so ago- if opened- bakes fine still…
any ideas what could I be doing wrong >?

thanks
Andrew

seem synoptic setup still works with both new and old rigs- might just be that something is wrong with rigbits>bake spring nodes

I’ll be quiet now

1 Like

Thanks for the feedback. I will check that, should work with the command or from synoptic