Home Website Youtube GitHub

Empty transform nodes when changing IK/FK blend to 100

This is another empty transform node thread from me, so apologies for that haha. The issue is “solved”, but posting to make others aware.
FYI: I’m working with Z up in maya and I’m unsure whether or not this has something to do with it.

Anyways, when creating the Unreal Mannequin Z-Up template and changing the right arm to be created with IK/FK Blend to 100 two empty transform nodes are created.

This only happens on the right side and not the left. (for me at least)
When building the rig and having the settings as default the joint hierarchy gets created normally.

I have seen the same kind of issue with regular mgear arms and legs.

While I didn’t find an actual solution, what worked for me was slightly shifting the elbow / knee guide position (which slightly affected the resulting angle) and those transforms were gone when I rebuilt.

This worked for me more than once and across different rigs.

Cheers! :slight_smile: