Website Youtube GitHub

Error when exporting guide template


#1

Hi guys,

I created a biped guide for a specific character.
I’m trying to export the template through the shifter menus.
But I’m getting the following error:

# Error: AttributeError: file C:\Program Files\Autodesk\Maya2019\Python\lib\site-packages\pymel\core\nodetypes.py line 414: nt.Locator(u’leg_L0_0_bone_controlBufferShape’) has no attribute or method named ‘form’ #

I don’t know what this form attribute is or how to dismiss it and work around it.
I started from the mGear’s biped template, so the leg module is actually originally from there and I don’t think I changed any of its settings.

I suppose I could just save the guide file as .ma without the rig and model, but I’d rather do things like they’re meant to and save the template as a .sgt

Any idea what I should do?

Thank you.


#2

probably this object inside controllers_org in the guide doesn’t have shape or is not a curve. Just delete it before export


#3

that happen to me when I selected anything else other than the controllers (Nurb curves) when clicking “Extract controls”.

like Miguel said, deleting empty groups or other stuff inside the controllers_org fixed the issue for me - and now I always go to the rig_controllers_grp set to select all the controllers (or use the Synoptic) before extracting the controls

image


#4

Thank you @Miquel and @Gui

I usually do select the set members for the rig_controllers_grp.
I think what happened is that I accidentally pressed my select hierarchy shortcut instead and used that selection to extract controls, which led to many non-curve objects in my controllers_org group.

I fixed it, and the export worked.

Cheers!