Home Website Youtube GitHub

Export skin bug

Hi, I have notice this bug everytime I am using the mgear export skin function where the skinning collapses a bit right after export.

Here is a a video.Watch the GEO closely:

Hi Ross,

  1. When you are using ngSkinTools, do you ever use any of the regular Maya skinning functions, like pruning, painting, mirroring, or anything? After you have layers, you can’t use Maya skinning anymore. That could cause issues, because it will store the wrong weight values, which ngSkinTools will override. But you might see the weights pop later.

  2. Can you please show your skinCluster settings in the attribute editor? For example, do you have maintain max influences turned on?

If you do have maintain max influences turned on, this could be causing problems too. I recommend turning OFF maintain max influences in Maya, and turning them on in ngSkinTools instead. ngSkinTools has a non-destructive version of maintain max influences. The result is pruned, but your layers stay smooth.

  1. You can try to normalize your weights. It looks like they are not normalizing properly to 1.0.
    Skin -> Normalize Weights -> Normalize Weights. Before normalizing, if you open the Component Editor -> Smooth Weights, do you see any weights not adding up to 1.0?

Otherwise, I’m still using ngSkin 1.7.8. I haven’t had the chance to test 2.0 yet. Maybe there is a bug there…

Here is a link to the file. I checked everything that you suggested and it seems in place.


In your skinCluster, you have “Normalize Weights” set to None.

Turn it to “Interactive” and it should fix the problem. Also make sure your skin weight options are set to Interactive when you make new skinClusters too.


Thank you so much Chris!

1 Like