Home Website Youtube GitHub

Extracting controls no longer working


I’ve been extracting controls (& mirroring them) fine, but now for some reason when re-building the rig it’s just building with the default shapes & sizes. I’ve checked through the other posts & can’t find an answer to fit.

I have only one controllers_org in my scene.

No errors at the end of the build log, only some mid script, not sure if related or not:

// Warning: While connecting reference array COG_C0_root was not found. This will be skipped. But you should check your guides configuration //

// The parent components for: local_C0 don’t have joint List in any of them use the root off guide. //

Also tried updating the guide but still not joy…

I’m working with the quadruped template
In Maya 2020
using mGear 4.0.7

Any help would be much appreciated :slight_smile:



The names have to match. And for the names to match, they have to be unique. For example, if you have 2 controls named “head”, it would show up as “|head” with the long name.

So to debug this, first pick one of the controls that isn’t working. And check the name.

example test_C0_ctl

  1. When you select the control, do you see the short name or the “|group|test_C0_ctl” longname with pipes in the script editor?
  2. If the name is unique, now go look inside your controllers_org group. Is your control there?

Search by name for test_C0_ctl_controlBuffer* with the asterisk on the end, so it finds controlBuffer, controlBuffer1, controlBuffer2, etc.

What you want to look for: Do you find test_C0_ctl_controlBuffer1? If you do, that could be another problem. Sometimes if you end up with duplicate names, you can end up with controlBuffer1 nodes. So your correct icons might be named controlBuffer1. And to fix it, you might have to delete the wrong controlBuffer, and rename controlBuffer1 to controlBuffer.

Otherwise every time you extract, it will extract to controlBuffer1 again, and then use controlBuffer when it builds.

And #3. If you don’t find the controlBuffer at all, that could mean a completely different problem with the extract script.


Thanks for the tips Chris…

It was indeed a duplicate name issue. Will keep an eye no that in future.

Thanks again :slight_smile: