Home Website Youtube GitHub

Frequent random crashes in 2024.2 when trying to work on animated mGear rig from 2020

Hi folks.

Are there any issues I should be aware of, where rigs done in 2020 with mGear cause regular but random crashes in 2024? The crashes are not specific to one thing. I could be in the graph editor, scrubbing the timeline, navigating the viewport, or translating a control.
I tried saving animation to Studio Library, bringing in the fresh unanimated rig, then applying animation to it. I also removed some softTweaks. The crashes seem less frequent but I’m still getting some. Is there any incompatibility (nodes or anything that may cause sudden crashes) between the old mGear in 2020 and new version in Maya 2024?
I can’t say it’s mGear, but all I have is an mGear rig in the scene.


I’ve now opened other characters created and rigged in mGear and 2020, and get multiple crashes in 2024. Unusable. Is there something I should be aware of? Perhaps GPU/hardware issues, and not Maya/mGear?

I did spot this, which seems to show it’s a Maya 2024 thing. I’ll install 2023.3 and see if this issue goes away. I’ll update this thread to let anybody who may be interested know.

Ok I’ve tried 2023.3 and Maya still crashes. I can scrub and go crazy in Maya 2020 with the rigs created in mGear in that version. Not so in 2023 and 2024 it seems. Crashes for all sorts of reasons, or for normal day to day animating behaviour. So I am no closer to a solution, other than to know I won’t be able to use these rigs other than in 2020… Any suggestions would be appreciated.

Another update. It doesn’t seem to be an issue specific to mGear. I opened a custom rig (no mGear) done in 2020 and the animation scenes using that sooner or later also crash in 2024.

You can try turning off GPU Override in the Windows → General → Evaluation Toolkit settings.

Sometimes you have to restart Maya for it to fully take effect. This alone has stopped a lot of crashing for some of my animators, for many Maya versions.

I also uncheck “Include Controllers in Evaluation Graph”, but I’ve never really tested it.

You might also want to try disabling Cached Playback, and see if that helps.

Thanks Chris.

I never use cached playback, but I’ll try some of those. Any new options are worth a try.

(edit) I thought those might be new things I hadn’t tried, but did actually try turning them off in the preferences.