Website Youtube GitHub

mGear Framework Forum

Guides not building full rig

Hello again,

So i’m continuing my newbie mGear adventures in trying to set up a guide for a simple quadruped.
And i’m running into a bit of a wall. I was step by step adding parts and then building them to see how things were coming along and testing as i went.

Everything was working fine UNTIL i added a “foot_bk_01” component to a “leg_3jnt_01” component.
Now when i select my guide and “build from selection” my front leg, front foot, and spine does not get built. if i delete the foot guide the rig gets built. (i’m only working on the left side of the rig for now once i got everything working i was planning on mirroring the full thing)

and also i have a simple “control_01” for a neck, head and jaw, and those don’t seem to link/build to the spine either. I’m sure its something really simple and silly that i’m doing wrong and i just can’t for the life of me figure it out. I would love to upload the .ma file but it seems i cannot. i guess a screen shot of my hierarchy will have to do.

Thank you!

P.S.
as i mentioned on the other topic my file is in Z up, i don’t know if this has anything to do with it.

do you see any error in the script editor log?

hello good sir!
Here’s the full list in the script editor.

= SHIFTER RIG SYSTEM ==============================================

= GUIDE VALIDATION ==============================================
Checking guide
Get options
Get controllers
Get components
global_C0 (control_01)
local_C0 (control_01)
center_C1 (control_01)
hip_C0 (control_01)
backLeg_L0 (leg_3jnt_01)
backFoot_L0 (foot_bk_01)
spine_C0 (spine_FK_01)
frontLeg_L0 (leg_2jnt_01)
frontFoot_L0 (foot_bk_01)
neck_C0 (control_01)
head_C0 (control_01)
jaw_C0 (control_01)
Find recursive in [ 0:00:00.323000 ]
Get parenting for: global_C0
Get parenting for: local_C0
Get parenting for: center_C1
Get parenting for: hip_C0
Get parenting for: backLeg_L0
Get parenting for: backFoot_L0
Get parenting for: spine_C0
Get parenting for: frontLeg_L0
Get parenting for: frontFoot_L0
Get parenting for: neck_C0
Get parenting for: head_C0
Get parenting for: jaw_C0
Guide loaded from hierarchy in [ 0:00:00.337000 ]

= BUILDING RIG ==============================================
Initial Hierarchy
Init : global_C0 (control_01)
Init : local_C0 (control_01)
Init : center_C1 (control_01)
Init : hip_C0 (control_01)
Init : backLeg_L0 (leg_3jnt_01)
Init : backFoot_L0 (foot_bk_01)
Init : spine_C0 (spine_FK_01)
Init : frontLeg_L0 (leg_2jnt_01)
Init : frontFoot_L0 (foot_bk_01)
Init : neck_C0 (control_01)
Init : head_C0 (control_01)
Init : jaw_C0 (control_01)
Objects : global_C0 (control_01)
Objects : local_C0 (control_01)
Objects : center_C1 (control_01)
Objects : hip_C0 (control_01)
Objects : backLeg_L0 (leg_3jnt_01)
Objects : backFoot_L0 (foot_bk_01)

Traceback (most recent call last):
File “C:\Users\owner\Desktop\mGear\release\scripts\mgear\shifter\guide_manager.py”, line 62, in build_from_selection
rg.buildFromSelection()
File “C:\Users\owner\Desktop\mGear\release\scripts\mgear\shifter_init_.py”, line 192, in buildFromSelection
self.build()
File “C:\Users\owner\Desktop\mGear\release\scripts\mgear\shifter_init_.py”, line 218, in build
self.processComponents()
File “C:\Users\owner\Desktop\mGear\release\scripts\mgear\shifter_init_.py”, line 396, in processComponents
comp.stepMethodsi
File “C:\Users\owner\Desktop\mGear\release\scripts\mgear\shifter\component_init_.py”, line 120, in step_00
self.setRelation()
File “C:/Users/owner/Desktop/mGear/release/scripts/mgear/shifter_classic_components\foot_bk_01_init_.py”, line 326, in setRelation
self.relatives[“root”] = self.fk_ctl[0]
IndexError: list index out of range

I would love to upload the .ma file but it seems i cannot.

Upload it to a sharing site like Dropbox, or your own server and provide a link.

So… from your description it sounds like you are building from selection on one part of your rig. And then building from selection on another part of your rig. And then trying to build the opposite side later?

Aren’t you ending up with a bunch of separate rigs? “rig”, “rig1”, “rig2”, etc?

I might not understand you correctly, but please consider using this workflow instead:

It’s totally fine to build from selection as a temporary test. But once your test is done, delete the rig and rebuild. From your description, I get the impression that you are not deleting the rig before you build again.

  1. Work on your guide.
  2. Build the rig and test it. (If you do any skinning export it to a skinPack)
  3. Delete the rig.
  4. Make changes to the guide.
  5. Build the rig and test it. (If you do any skinning export it to a skinPack)
  6. Repeat.

(I don’t know if there are alternative ways of building a Shifter rig, but that is how I work.)

i can’t believe i didn’t think of just uploading the file to google drive… this is what happens when you try to rig at 2 am after you’ve put your 8 month old twins to sleep…

Here’s the file : https://drive.google.com/file/d/1pJao25Sh0zD02f-vkwxrqJK_Rn8EA9Sv/view?usp=sharing

As for the work flow, i have been deleting the “test” rigs every time. The whole thing comes apart when i add a foot controller to the rear leg. i got back to the “root” guide in my outliner select it and when i click build from selection, it stops building parts of the rig like the front leg and spine and all the other stuff i mentioned in the initial post.

In the file if you delete the rear foot controller it will start working, (minus the neck, head jaw) but once the foot controller is there the spine and front leg stop being generated.

I get the same error when trying to build. It is definitely not the Z-up setting.

In the quadruped template, the foot has 2 segments:

image

Your guide only has one:

image

In the quadruped template, if I delete that 2nd node, “footBack_L0_1_loc”, I get the same error as you.

This appears to be a bug or a limitation with the foot_bk_01 component. It fails if you make a fresh foot component and choose 1 in “Sections Number” options. It also fails if you manually delete the extra _loc segments.

To avoid this bug, it looks like you need to choose 2 or more sections.

image

(Perhaps this could be fixed in the foot_bk_01 code, but I don’t quickly see any obvious fix. But I only dug around for a few minutes.)

3 Likes