Home Website Youtube GitHub

Hi, Im having trouble with game tools

I made a rig using components that shfiter provides and it works great when it comes to animation.
but when I try to export the rig with shifter-game tools, it raises an error saying

# Traceback (most recent call last):
#   File " (..) \shifter\game_tools.py", line 541, in disconnectExport
#     name, rigTopNode, meshTopNode, path, postScript)
#   File " (..) \mgear\core\utils.py", line 205, in wrap
#     raise e
# IndexError: list index out of range

I tried with shfiter’s biped template too and exportation worked fine.
problem is only with my rig(or the scene)
could you give me any idea of what would cause this kind of error?

Hello @hairyeel99

It is hard to tell only by the error log. Can you share your rig on a PM?

I have a similar issue. Was there a solution?
Thanks.

Hello @maczolaci
Not sure if @hairyeel99 found a solution. I think, I never I have received the PM. (@hairyeel99 did you found the solution? )

@maczolaci The new mgear will have some updates for the game tool. Nothing new in the interface but should slit better the rig from the joints and mesh.
If you can share sample data will help to debug the issue.

Cheers,
Miquel