Home Youtube GitHub

How to set humanIK for mocap?


#1

Hi
i’d like to set up humanoid character with reference to movie humanIK & Mocap.

when set control rig, humanIk controller is connected only spine and toe base joint.
but Arm and the other (leg, head and…) is not connect to humanIK.

What am I missing.
my project’s humanIk have some roll bones, is it cause?
how can i connect them by myself?

my trying ver is mGear 2.61 / 2.5.24, maya : 2017 / 2018

thanks.


#2

Honestly I didn’t try it until now ,but Miquel said something in the video in minute 0:57 that this method is hard-coded to mGear default Biped template, if you make some changes to your build from this default template (you said you have some roll bones), It may fail somewhere else … so I think they are the cause :thinking:

anyways, did you try with the very default biped built from the default template? without your roll bones?


#3

Hi Hazem.
After this post, i tried it without humanIK rollbone. but didn’t work it.
but I tried default humanIK and default mGear biped in new project, that works without problem.

Next, I thought i settings mGear Biped bone division that is cause.
I reproduced the state and test in new scene without my geometries,but in the project humanIk works.

Maybe my project have some issue. I tried set up many times. and i have other issue like that the hierarchy shifted when duplicated symmetry. i don’t know why these problems happen.

Is “Warning: global_C0_ctl: Is not in the scene” related this issue?
when executed characterize biped more than once, this warning is displayed.
and not working characterize biped. Is it just me?

Finally I set up rig again.(but not working)
Thank you, Hazem. I appreciate what you have said.

Please let me know if you have any question and concern.Thanks.


#4

That’s a good amount of tests you did . Likely the whole issue is that you need default bipeds of mGear & HIK to guarantee all will work well. it’s not practical I know, as we always customize the mGear biped.

Am not in front of my PC now, just replying from my phone, later when I can I will do few tests & reply here again if I found any news other than what you discovered above.


#5

I found the cause of this issue.

At first I set 4 to spine’s number of division. running characterize mocap, humanIK definition warning about “some spine is same point.”
I tried the number of division to set more than 5, humanIK have no issue and I can import animation to mGear rig.(I can set roll bones.)

thanks.


#6

@tsukiha I am glad you find the issue. As @Hazem_Mahmoud commented the current solution is very limited and only works with the default biped. So any change in the template guide may cause an error in the tool.