Website Youtube GitHub

mGear Framework Forum

I have a wrist rotation problem

I’ve followed the tutorial’s guide and made my rig with mGear. But my wrist control doesn’t work at all. I cannot rotate the wrist. [wrist|690x453]


I’ve made the wrist rig several times. The results are the same, it doesn’t work.
What did I do wrong?

Hi @jamesrigger
Please check this option setting for the rotation tool.

thanks for answering my question.

I checked out the option settings for the rotation tool.
I don’t check on the option, however it still doesn’t work.

@jamesrigger
Does everything work except for the wrist?
Is your guide custom or the system’s default bipedguide?
Does this problem occur in the default bipedguide?

Hello @jamesrigger

If you are on IK and you selected to build the Ik Arm with rotations into a separated control then it is normal that the IK control do not affect the rotation of the wrist/hand. Could you please share you guides template please so that I can take a look?

Cheers

yes, everything’s good except for the wirst.

My guide is the system’s default bipedguide.

yes, it occurs in the default bipedguide.

I don’t know yet how to set the custom guide though.

This is my guide. Take a look at it plz.

https://blog.naver.com/jamesjuwon/221805444172

thx.

@jamesrigger

I checked your guides. The issue comes from your guides. You need to parent your meta_L0_root and armUI_L0_root under the arm_L0_eff node. Same for the other side I guess :wink:

Cheers

2 Likes

oh! Bravo!!!

I fixed my parenting problems you pointed out.
It’s working perfectly.

Thanks to you, Jerome, my headaches go away.