Website Youtube GitHub

IK/FK Leg rotation values not zeroed when set to FK


#1

I can’t seem to find a good workaround for this problem. When I change my IK leg to FK the Leg_Root has non-zero values. Has anyone else encountered this? I can’t seem to find a way to resolve this, even by parenting the Leg_Root to a custom Hip Control that has a matched rotation value.

Any ideas?


#2

Just quick look at my dinosaur rig, the "legBack_L0_root"group object dose has rotate value too but instead

we key animation on legBack_L0_root_“CTL” object right? (It’s zero out in my dinosaur rig.)

I think the “root” group object is for rigging process not for animation.

Not mGear expert but I use “addNPO” function often when dealing objects that I want them to be zero out .

Wish it helps.


#3

Thank you for that. I really appreciate your insights. Unfortunately, the object that has a non-zero value is “leg_L0_fk0_ctl”. I think your idea of using an NPO to zero it out is a good one, I just wanted to find a way to fix it before the build so that I don’t have to correct it every time I rebuild the rig.

I am in the middle of a production and having to do lots of little fixes to the rigs to help the animators and myself. My python scripting isn’t so good, so adding a post build script isn’t much of an option at the moment.

I think worst case scenario I will use your NPO idea just so it zeros properly when resetting the pose.

Thanks again.


#4

I think maybe you can attach scene file or guide component setting screenshot here. Someone can definitely find the solution for you.


#5

Good suggestion. I followed your advice and uploaded an image. Thank you for your help.

Dan


#6

Yeah the “leg_ms_2jnt_01” component did have initial FK rotation value after build.
Maybe the parent “leg_**_fk*_npo” grp object didn’t do the zero out job or its intentionally this way.

Arthur


#7

I am not using these components in production, so I didn’t notice it. But yep! that looks like a bug

logged in github:


#8

Which leg setup do you typically use in your productions, or do you create your own? I suppose I may be too far along to change at this point, but it might be worth looking.


#9

Oh ha, sorry, thanks for the reply. I appreciate it.


#10

As for being too far along, here is a tip. You can change the type of a component just by going into the attribute editor and changing the .comp_type attribute on the guide. If the guide nodes and settings match, you don’t need to re-rig the guide. You just tell it that it is something different now, and it will build as the new type.

I don’t know about leg_2jnt_ms_01. But I was able to change my legs from leg_2jnt_01 which the default biped template uses, to leg_2jnt_freeTangents_01, which is what I always use. All I had to change in the guide was “Divisions” to 2 and 3, so it had the same number of joints, and then it built fine and my skinning even matched.

Those two components have all the same guide settings, so all your ikref values should stay the same. Any post scripts might have to change, since some of the controls it builds will be slightly different.

(If you already have animation done, this might not be a good idea, without testing first.)


#11

Wow, thank you for this. It is very helpful. I will test this right away. Amazing. Much appreciated.

Dan