Website Youtube GitHub

mGear Framework Forum

Installing mGear in Maya 2020

I’m a new user and cannot seem to get mGear installed. I’m on Windows and using Maya 2020.

In my .env file I have a line declaring:
MAYA_MODULE_PATH = $MAYA_APP_DIR\2020\modules;

In that modules folder location I have dropped the contents of the .zip file from github. I have tried installing the previous version as well as the latest (3.6.0) with no luck.

I’ve followed all three recommended ways on the mGear youtube channel and none of those has worked for me. I have also ran the process with default maya prefs…no go. Anyone have thoughts about what I might be doing wrong?

Maybe the problem is \ backslashes. Try changing it to either use / or \\ double slashes in your paths.

MAYA_MODULE_PATH = $MAYA_APP_DIR/2020/modules
MAYA_MODULE_PATH = $MAYA_APP_DIR\\2020\\modules

Did you put the “releases” folder in /modules, or did you put the stuff under releases into /modules? (The 3 things under releases, is the right way.)

1 Like

Also, you shouldn’t have to declare the modules directory. You only need to declare a MAYA_MODULE_PATH if you are using a custom path somewhere else on your computer. Maya already knows to check …/modules.

1 Like

Yep - just to confirm, Chris is right - that’s how we are declaring our module path and it works in 2020

1 Like

Thanks for the replies, Chris and Jason.

I’ve tried back-slashes and double slashes, but as you mentioned even declaring that variable shouldn’t be necessary since I’m putting it in /modules .

Here’s what my modules folder has in it:
mGearModules

Any other ideas of things to try? I’ve never had so much trouble getting a plugin to load in my life. :cry: I’m sure it’s something silly.

I’m stumped…

  1. So just to be clear, I’m expecting that none of these are working for you, but could you check, just in case some of them are, and it offers any clues?
  • If you open your Plug-In Manager in Maya, and search “mgear” do you see the mgear solvers, loaded or unloaded?
  • If you open your script editor and type “import mgear” in a Python tab, do you get the error // Error: ImportError: file <maya console> line 1: No module named mgear //
  • If you open an mgear rig (if you have one), does the rig collapse, because the solvers haven’t loaded?
  • When opening Maya, you do not see “mgear” in the top menu of Maya?
  1. Do you see any errors in your script editor or output window when opening Maya?

  2. Just for debugging purposes, could you copy/paste the full path to your prefs folder? In your screenshots, it looks normal, but just in case. (If you shift-right-click on a file in Windows, you can copy the full path.)

And if you run this Python, what does it print? Is it returning the correct prefs folder that you are expecting? (You don’t have to share your path here, but at least compare them for yourself.)

import maya.cmds as cmds
print cmds.internalVar(userAppDir=True)
print cmds.internalVar(userPrefDir=True)
  1. Are you declaring any other module paths in your Maya.env file? Also just to be super crystal careful, you said “my .env file”. Can you please confirm that you mean maya/2020/Maya.env?

Can you copy/paste the entire contents of your Maya.env file to check for typos or syntax errors?

  1. Finally, my last guess. Delete mgear from your modules directory. Keep it in some other folder. And try directly pointing to the /release folder that you downloaded. Maybe you have some obscure folder permissions problem or something…? example:
    MAYA_MODULE_PATH = C:/Downloads/mgear_3.6.0/release
    Any difference if you do that?

One last stab in the dark. Reading the help page on $MAYA_APP_DIR, there are inconsistencies in the examples between Windows and Linux. But in the Linux examples, it shows

$MAYA_APP_DIR/maya/2015/plug-ins
instead of
$MAYA_APP_DIR/2015/plug-ins
Even though it states that the variable returns the path including /maya at the end. So that doesn’t make any sense.

So maybe you need to include /maya/ in that path. But I suggest, until you have it working, or unless you are absolutely clear what $MAYA_APP_DIR returns on your system and OS, to just explicitly use the full path in your Maya.env file until you have this debugged.

example:
MAYA_MODULE_PATH = C:/YourUserName/Whatever/maya/2020/modules

Even though again, you shouldn’t even have to declare this at all.

I really appreciate the help, thank you. After running through that list, it looks like the plugin is loaded, but I’m just not getting the menu, so I can open scenes with rigs, but can’t do any actual rigging tasks. Is there a script I can run to force load that menu?

1.)
I do see the mgear solvers plugin and it’s loaded.
-when I run “import mgear” nothing happens, and I get no error in the script editor.
-I downloaded the “SpiderVerseRig_v2” rig and that seems to work just fine. No collapsing.
-I do not see the “mgear” menu in the top of Maya.

2.)
I don’t see any errors on startup that seem to relate to mGear, but here’s what the script editor pops up with on launching Maya:

// untitled //
commandPort -securityWarning -name commandportDefault;
onSetCurrentLayout “Maya Classic”;
// AbcImport v1.0 using Alembic 1.7.5 (built Feb 6 2018 18:28:08)
// AbcExport v1.0 using Alembic 1.7.5 (built Feb 6 2018 18:28:08)
evalDeferred “shaderBallRendererMenuUpdate”;
// Warning: file: C:\Users\Joe Daniels\Documents\maya\2020\prefs\filePathEditorRegistryPrefs.mel line 4: filePathEditor: Attribute ‘aiImage.filename’ is invalid or is not designated ‘usedAsFilename’. //
// Warning: file: C:\Users\Joe Daniels\Documents\maya\2020\prefs\filePathEditorRegistryPrefs.mel line 5: filePathEditor: Attribute ‘aiPhotometricLight.aiFilename’ is invalid or is not designated ‘usedAsFilename’. //
// Warning: file: C:\Users\Joe Daniels\Documents\maya\2020\prefs\filePathEditorRegistryPrefs.mel line 7: filePathEditor: Attribute ‘aiVolume.filename’ is invalid or is not designated ‘usedAsFilename’. //
// Warning: file: C:\Users\Joe Daniels\Documents\maya\2020\prefs\filePathEditorRegistryPrefs.mel line 9: filePathEditor: Attribute ‘dx11Shader.shader’ is invalid or is not designated ‘usedAsFilename’. //
// Warning: line 1: filePathEditor: Attribute ‘aiVolume.filename’ and label ‘VDB’ have been saved already. //
// Warning: line 1: filePathEditor: Attribute ‘aiImage.filename’ and label ‘Image’ have been saved already. //
// Warning: line 1: filePathEditor: Attribute ‘aiPhotometricLight.aiFilename’ and label ‘IES’ have been saved already. //
import arnold
// Successfully imported python module ‘arnold’
import mtoa
// Successfully imported python module ‘mtoa’
import mtoa.cmds.registerArnoldRenderer;mtoa.cmds.registerArnoldRenderer.registerArnoldRenderer()
// Successfully registered renderer ‘arnold’
updateRenderOverride;
// Warning: file: C:/Program Files/Autodesk/Maya2020/scripts/startup/autoLoadPlugin.mel line 35: Loading plug-in “mtoa” has resulted in changes to the scene that may need to be saved. //
updateRendererUI;

3.)
-Here’s my full prefs path:
C:\Users\Joe Daniels\Documents\maya\2020
And after running that script here was the printed result:
C:/Users/Joe Daniels/Documents/maya/
C:/Users/Joe Daniels/Documents/maya/2020/prefs/

-Yes, by my environment file I was referring to the Maya.env in the 2020 prefs folder listed above

4.)
I’m not declaring any other module locations in my environment folder. I do have a custom environment file for work plugins and directories, but even when I do this process with clean prefs and a blank environment file I still have issues getting the “mgear” tool menu to load. Here’s what is in my custom environment file, though:

MAYA_MODULE_PATH = $MAYA_APP_DIR\2020\modules;
MAYA_PLUG_IN_PATH = C:\Perforce\Tools\shared\maya\plugins;$MAYA_APP_DIR/2020/scripts;
MAYA_SHELF_PATH = C:\Perforce\Tools\shared\maya\shelves;C:\Perforce\Tools\potter\Shelves;
MAYA_SCRIPT_PATH = C:\Perforce\Tools\shared\maya\scripts\mel;C:\Perforce\Tools\potter;C:\Perforce\Potter\Art\3D\Setup\scripts\mel;
PYTHONPATH = C:\Perforce\Tools\potter;C:\Perforce\Tools\shared\maya\scripts\python;C:\Perforce\Potter\Art\3D\Setup\scripts\python;
XBMLANGPATH = C:\Perforce\Tools\shared\maya\images;C:\Perforce\Potter\Art\3D\images;$MAYA_APP_DIR/2020/prefs/icons/morphy;$MAYA_APP_DIR/2020/prefs/icons/Anim;$MAYA_APP_DIR/2020/prefs/icons/JoesIcons;$MAYA_APP_DIR/2020/prefs/icons/SFN;MAYA_PLUG_IN_PATH = $MAYA_APP_DIR/2020/scripts;$MAYA_APP_DIR/2020/prefs/icons/wiz_icons;$MAYA_APP_DIR/2020/prefs/icons/wiz_icons;
PYMEL_SKIP_MEL_INIT = 1;

5.)
I put it in my downloads folder and changed the modules path to match as suggested. The plugins show up and are loaded, just like they were when it was in my modules folder, but I still get no “mgear” menu.

I wonder if your work environment or any other plugins are still somehow interfering. Do you have animBot installed? Do you have any other plugins installed which perhaps install themselves in a directory that Maya would call even with clean prefs?

For example, if you navigate to the Maya installation folder under Program Files, there also exists a plug-ins and modules directory, which Maya also loads. That is where plugins like xgen, MASH, or Substance are installed.

Could you go find those folders, and temporarily rename them to modulesTEMP and see if your menu appears?

There is also a chance your work may have added other environment variables for other installation locations. If you go look there, you may find some other paths that are related to Maya.

Or sorry, for a simpler way without diving around in your program directories, you can try running this script in Maya. It will print all the paths of loaded modules.

import maya.cmds as cmds
allModules = cmds.moduleInfo(listModules=True)
for eachModule in allModules:
    print cmds.moduleInfo(path=True, moduleName=eachModule)

And the reason to try this, is to find out if there are any loaded modules which interfere with mGear’s ability to display the menu. Since other people have had similar problems, without understanding why, yet.

Gotcha. I cleaned my prefs completely and just added the modules folder with the mGear stuff in it. That way there’s nothing of my prefs in there, just what Maya 2020 comes with by default. I enabled the mgear plugin, and then I ran that script and here was the result (still no menu appearing):

C:/Program Files/Autodesk/Maya2020/plug-ins/ATF
C:/Program Files/Autodesk/Maya2020/plug-ins/MASH
C:/Program Files/Autodesk/Maya2020/plug-ins/fbx
C:/Program Files/Autodesk/Maya2020/plug-ins/camd
C:/Users/Joe Daniels/Documents/maya/2020/modules/platforms/2020/windows/x64
C:/Program Files/Autodesk/Arnold/maya2020
C:/Program Files/Autodesk/Maya2020/plug-ins/camd
C:/Program Files/Autodesk/Maya2020/plug-ins/camd
C:/Program Files/Allegorithmic/Substance in Maya/2020
C:/Program Files/Autodesk/Maya2020/plug-ins/xgen

I also renamed these folders:
C:\Program Files\Autodesk\Maya2020\modulesTEMP
C:\Program Files\Autodesk\Maya2020\plug-insTEMP

Still no luck getting the menu to pop up upon launching Maya.

Sorry for your troubles, that’s all I can think of.

Have you tried older versions of mGear? All the way back to 3.2 or 3.4 perhaps?

Hello @joedanimation

Will you be up to a zoom session with me where you can share your screen and we try a step by step installation?

Seems pretty unusual having all this issues making it work. There’s probably something silly that we ignore about your setup/config.

Let me know if this is possible for you and if I can send you a private message with a link for this.

Cheers

2 Likes

Absolutely, I would appreciate that. I can make an opening in my schedule any time today, or afternoon tomorrow. I’m in the pacific timezone, btw.

Just a quick head’s up to close this thread about the installation. The issue was due to errors caused by a preceding userSetup.py file. The way @joedanimation had mGear setup on his end was correct, just failed to load due to Maya’s cascading effect on loading time.

Thanks @chrislesage for the help :ok_hand:

3 Likes

Yes, I’m good to go now. Thanks for the help, everyone!

1 Like