Website Youtube GitHub

Is mGear using a GPU cache and can it be disabled?


#1

Hello there,

I’m currently working on my diploma film and we are using mGear for the bodyrig. We are now animating the shots but I ran into a problem that maya crashes every few minutes (I set autosave to 10min but it never get’s to that point before it crashes). We tried several things, even switching computers and someone mentioned that mGear uses GPU caching to boost the performance. It seems that this is what makes Maya crash but we are not sure.
Is there a GPU cache that runs in the background and is there a way to disable that to see if that is the problem?

We tried it with a GTX 1080 and an RTX 2080 TI and we are using mGear 3.1.1 and Maya 2018.6

All the best


#2

Have you tried setting your maya to evaluate in DG or serial mode?
Link


#3

Setting it to DG or serial is a great way to test if parallel eval is the problem, but it isn’t a good final solution, since it will make your scenes a lot slower.

@FynnGB
Are your graphics cards drivers up to date? This helped us with some crashing problems on our film, on some computers sometimes. Another computer required a fresh install of Windows before it stopped crashing. Dark arts here…

What OS are you using?

The mGear animbits cache manager is a tool you have to run, and as far as I know it is just a front-end for the Maya gpuCache. It isn’t something that is running in the background. Documentation here.

Are you using animation layers? That is a very typical cause of Maya bugs… Only brave souls use animation layers.

I also suggest testing in Maya 2018.5. I tried testing 2018.6 on Windows 10, and ran into a lot of crashes. And I only tested it quickly for one morning. We decided to stick with 2018.5. This is a total game of luck. It might not help you, but it is worth a test.


#4

Thank you very much for the fast replies!

I have Windows 10 Education 10.0.18363 Build 18363 installed.
Ha! We are not brave enough to use animation layers. Using DG seems to work for now but you’re right it makes it much slower. But it might work for a while until we found the root of the problem
I will talk with our technical director tomorrow to see if we can switch the pipeline to 2018.5 to see if it makes a difference.
On thing that might be of interest is that Maya just freezes and then closes without an error warning or fatal error. It happened a few times that when I didn’t close it with the task manager that the entire computer would freeze and I would need to force shut it down.

Thank you very much again and all the best! I will write again if something new comes up.


#5

Oh the entire computer freezes? That could be a memory problem. Do you use Wacom tablets?

On Windows 10, there is a terrible bug where the touch driver will memory leak until the computer completely freezes. I’ve seen multiple people with the same complaint on forums. Running out of memory would also cause Maya to crash if Windows doesn’t crash first.

I suggest checking if your memory is filling up. If it is, and you have Wacom drivers installed, try this:

In the task manager kill “Touch User Mode Driver”. It will not affect your Wacom pen. But it will stop that memory leak if it is affecting you.

This might not be your problem. For me, this bug only happened once or twice a day. Not every 10 minutes. But I would monitor your memory and see.

Otherwise… no, Maya freezes often. That isn’t “of interest”. It’s just a regular day in Maya. :slight_smile:


#6

Hello @FynnGB

If you are having a lots of crashes due to the evaluation manager just try settings the following settings like on the picture.

Be aware that the ones on BLUE don’t get saved out in Maya 2016 - 2018 (don’t know about 2019) so this means every time you start a new Maya you need to turn those off again.

Give it a try and let us know.
Cheers


#7

Thanks a lot!

I actually use a tablet from huion but it could be a similar problem. The DG seemed to work fine which was a relief already but I will try out the other settings as well to see if that fixes it and still get the performance from the parallel evaluation.

I will keep you updated how it goes! Thanks a lot again it’s great to get such fast replies after dealing with it for several days on your own!