Website Youtube GitHub

Issue with rigging the 2nd eye


#1

So I’m using a rig from mixamo, which is just fine when it comes to rigging the mouth and the first eye but as soon as I rig the 2nd eye this happens

I tried different ways and nothing seems to work
Ty for any help!


#2

When a skinCluster already exists, I seem to remember that the eye auto-skinning fails. I can’t tell if that is your problem or not from this picture. But this is what I do to work around that particular problem:

  1. Build the left eye with auto-skinning turned on. Export that skinning as an ngSkinTools file.
  2. Go back to guide file, or delete the rig.
  3. Build the right eye with auto-skinning turned on. Export that skinning as an ngSkinTools file.
  4. Go back to the guide file, or delete the rig.
  5. Build the rig AND both eyes with auto-skinning turned OFF.
  6. Add the eye joints to the skinCluster and import the eyelids ngSkin layers on top of the other skinning.

(That might not be your problem if your mouth was already rigged, and the first eye didn’t fail.)


#3

is there maybe another way of working around this? I fail doing what you suggested since im not too sure what im doing as well

Btw, i forgot to mention that when i rig it , its rigged and all, it’s just that im sticking out like that


#4

Are you using Dual Quaternion weight mode? It looks a bit similar to DQ weights when you have non-uniform scaling. Maybe your right joints are getting flipped in scale or something.

What happens if you export the skin weights, delete the skinCluster, and then import the weights again? (This would reset the skinCluster after the joints are flipped, and might fix it.)

You can export the weights with mGear -> Skinning -> Export weights

Otherwise, more details from you or an example file would help.


#5

Honestly I havent gotten to that point where I pick the weight mode

So I’m attaching the file here maybe you could look at it, im using the lastest mGear, and the model is rigged with Mixamo

File download link -->> https://files.fm/u/qmpbttju

Let me know how it works out for you

(THANKS A TON)


#6

Please try the steps I said first. Did it make a difference?


#7

So I exported the skinning on the left eye, deleted the the skinning then rigged the right eye and imported the skin from the left eye i exported and got this

*Also. Dual Quaternion didnt make any change


#8
  1. Finish building the rig with both eyes. Get to the point where you took your original screenshot. Fully complete.
  2. Export the skinning.
  3. Delete the skinCluster. Not the rig.
  4. Import the skinning.

I never mentioned to rebuild the rig. You’re just going to cause the same problems as before if you rebuild the rig. You just want to reset the skinCluster to neutral, AFTER the rig has been built. My wild guess is that some joints flip after the skinning happens.


#9

I think you need reset you rig to “bind pose” and try again. The rig you attached is T-pose but not bind pose which is “A” pose. And the steps Chris mentioned above are useful when you got skinning problem using eye rigger.
The first eye build successful but not second maybe due to some offset between A and T pose.
Hope it helps.


#10

Thank you arthur!

I did set my model to bind pose - A pose ( which I didnt know existed since I imported a T pose from mixamo but upload it as A pose! )

and i worked but now im stuck with a new problem which I tried fixing, by parenting those joints to any part of the rig but rig is moving really slow like it feels laggy/ heavy

I also tried using the ‘Options’ -> ‘Rig parent’ and parented to the joint as the eye and it seems move slow as if something’s not right

Thank you!


#11

Just parent “eye_R_root” , “eye_L_root” to Head_CTRL should fix your problem.


#12

Thats exactly what I did but it makes rig laggy / heavy as soon as I parent them


#13

Actually I done the same thing again and it works smoothly now… not sure what I did exactly different but… solved i guess! :smiley: