Home Website Youtube GitHub

Lag issues when using multiple rigs

Hi people,
I’m having a major issue when using multiple mGear rigs in scene. I’m trying to load around 30 characters and I know with that I will have a very heavy scene. I was expecting that, the problem is, every time I try to scrub the timeline I get an huge lag, that disappear after the first scrub, the scene then goes to
2.5/3.0 fps, which is normal, but before that the scene just get stranded for about 6 sec, and that’s the really issue. That keeps happening after moving anything, like changing viewport or creating new keyframes.

Of course, using cache manager, loading/unloading the models it helps, but that’s not the idea. Before working in each individual character I need to have most of them in scene, and as I said, the issue is not to have a heavy scene in hands, is to get an unusually lag before anything else.

This issue doesn’t happen with other rigs besides mGear and therefore I would like to know if this happens to anyone else and if there’s a solution, a missing plugin or missing a python code.

Further more I will post some videos here, I can’t show the characters in hand, but we see the frame rates.

Sample with 10 rigs:

Sample with 50 rigs (more simple rigs, but no issues):

I tried lots of solutions from working directly on the SSD disk to upgrade the RAM from 16Gb to 32Gb, but the only thing that came out with some result was to disable Maya check cycle “cycleCheck -e off;” which avoids looking script loops in some rigs.

So, please if anyone come into this problem let me know and hopeful some of you found a smart solution for this.
Thank you very guys. Cheers
Jose Carlos P

Should probably try and set the evaluation mode back to DG.

Nop, Sorry Noll, that was the first things I tried, but it gets even worse.
I also tried to use Maya 2019 for caching geometry but didn’t get any difference.

Hello @Jose_Carlos_Poeiras

it is hard to tell without the data to test
can you profile the scene? Maybe that will show where is bottlenecking. Also if you can share some data will help. Maybe the scene without geometries

Ok, I will look into that. Project is almost over when, I see if I can send the rigs as a test.
And when I have a chance I send you the scene profile, maybe you see something weird.

Ok, I found out where the issue happen.
It’s always when any “EM state” needs to rebuild. However I would hope this didn’t happen so often and to be a lot faster as is in many other cases.

Also, not sure why the scene profile shows up like this:

such huge chunk of “dirty propagation” is an issue?

You mentioned trying Maya 2019 but what about 2020.3? Perhaps putting key frames on all the rig controllers?

:thinking:
Didn’t try this scene in Maya2020, but I thought that feature was already implemented in 2019 (caching controllers with keyframes)

are you using Redshift3D? in the old version 2.5 it was doing something similar. Not in newer versions

It’s 2.6.41 … humm, do you think It can be mixing up things!?
I will give it a try and install 3.0.

Anyways I don’t any renders, only suits to load up scenes properly.

Maybe this: [Maya] Added the mel script command “rsNodeMonitor” with the flags -enable, -disable, and -stop to reduce FPS slowdown after loading Redshift

https://www.redshift3d.com/forums/viewthread/25892/

https://www.redshift3d.com/forums/viewthread/25892/P15/#162586