Website Youtube GitHub

mGear Framework Forum

Leg_3jnt_01 unwanted stretchiness

For a project I need a solid quadruped setup, for which the 3jnt seems to be the logical hind leg solution. I already notice some issues mentioned on this forum. I also have one.

It is important to me (and the future animators) to not have any form of squash and stretch. If I turn this of (by setting stretch to 1) I still experience local stretch when one of these controllers are translated:

legBack_L0_ankle_ctl
legBack_L0_knee_ctl

The ankle even produces very weird non-uniform scaling on the bones (shearing?).
I use the rotational plane method because the spring-option gives a faulty bone-chain which does not follow the guide. Both methods generate the stretch/shear.

Is this a bug or am I using it the wrong way?

Cheers
Michiel

If you select the “guide” group and open the shifter settings, there’s an option to “force uniform scaling for all joints.” It may solve the problem.

1 Like

Hello @mackerB

That controls are offset controls. If you want to avoid the animators touch it, just block and hide the channels . You can also hide the Shape of the controls to avoid any confusion to the animators.

for the uniform scaling try with the recommendation from @Aerys

I hope this helps :slight_smile:

Cheers,
Miquel

Hi @Aerys and @Miquel. Thank you for your answer.
Checking the ‘force uniform scaling’ did not change the behavior, it still stretches the hind lower leg. The stretching happens by translation, while squashscaling inwards.

I could hide those offset controls but when one rotates through the ‘legBack_L0_roll_ctl’ or the ‘legBack_L0_ik_ctl’ the leg length out of range, the lower leg starts to stretch automatically. This also happens when translating the ‘legBack_L0_ik_ctl’. We work with a ziva-system so in no way the bones should be allowed to separate.

If you would be able to guide me to a way to avoid this I would be much obliged…
Cheers
Michiel

is the connector in the foot is set to the corresponding leg component?
image

Yes, it does:

@mackerB can you send me the guide in a PM?

I would like to check the configuration.

In the quadruped template doesn’t stretch
image

I used Leg_3jnt_01 in my recent project.
These two controllers “legBack_L0_ankle_ctl” and “legBack_L0_knee_ctl” are locked and hided in my rig .
Maybe you can check “Stretch” value setting. It should be 0 to avoid stretching.
image