Home Youtube GitHub

Lips rigger breaks while using jaw control


#1

Hey guys,

Sorry to bother. I’ve been facing this problem from quite a few days. I tried whatever i can to solve this issue but nothing works. The thing is couldn’t even debug why this problem was happening to begin with. So in some scenes when animating the jaw with lips rigger there seems to be a breakdown at some places as shown in the video. If i tweak around the jaw control a little bit the problem goes away. This problem is occurring to me in only a few cases and even if I copy the same values of the lips and jaw to the same rig in another file it works fine. I’m sorry I couldn’t upload the actual file in which the error is occurring as it belongs to the studio.
In this rig I parent constrained the ‘lips_C_crvs’ with ‘mouth_C0_lipup_jnt’ & ‘mouth_C0_liplow_jnt’ for the lips to follow the head properly.

Here is the link showing the issue: https://drive.google.com/open?id=1pORMh6dlLbNiY1i9WJTS-KmnR5qmQynJ


#2

Hello @niteshms04

Is it possible to provide your test scene? Miquel having more experience than myself with the component I can’t tell if he has already experienced this issue. For me it seems like a math issue at some points but I can’t be sure.
You can send me this is a private message if you are bound to confidentiality restrictions. It will help me track the issue correctly.

Thanks


#3

If you parent the “lips_C_crvs” group to the “neck_C0_head_ctl” you will get rid of the popping. That is what i did to get everything to work. Have done it now on 8 rigs for now and it resolves the issue.


#4

I did that but it’s still happening. With Jerome’s help I learned that its happening when the global is rotated 180 degrees. For now I added the lips rigger to a duplicated mesh and blend shaped it to the original mesh. Since the blend shape mesh and lip controls wont be rotated its not causing much issue. Thanks for the help.


#5

Hello @niteshms04

Sometimes the parent constraint in Maya flips depending of the configuration and situation if the parent constraint has 2 or more inputs. That is the reason this constraint has several option to solve the interpolated position:
image

Can you check if the problem is solved changing to another configuration on the Interp Type?

Cheers,
Miquel


#6

Hi,

Never knew there was something like this in the constrains. Thank You, its working properly now.


#7

Good to hear that fix the situation. :slight_smile: