Home Website Youtube GitHub

mGear menu not showing up

the mgear menu isn’t in the viewport. It’s nowhere to be seen. It’s working and older models i’ve used are working but i don’t see mgear anywhere. In the YouTube tutorial I saw it just pops into existence, that’s not the case for me.

Hey @Luis_HerreraPortillo

  1. In your script editor, can you run import mgear without getting an error? That tests if the module is loaded properly.

The rigs will still work if the plugins load. But if the mgear module doesn’t load, then you won’t be able to run mgear scripts, or see the menu.

If the module is loaded, but the menu isn’t showing up, that’s something different, and we’ll have to debug further.

  1. Can you run import pymel.core as pm without getting an error? If no, then maybe you didn’t install PyMEL. But I think you would be seeing errors already if this was missing.

  2. This happened to someone else, and they fixed it by resetting their preferences. Close Maya. Save a copy of your preferences first in case the test fails and you want to go back. Then delete the 2022/prefs folder. Depending how you installed mGear, you might have to reinstall, since the module files might be inside your prefs folder.

Personally, I install via Maya.env, not the drag and drop installer. It makes switching versions much cleaner. Example, save the files somewhere on your production drive, instead of in your prefs:

MAYA_MODULE_PATH = P:/production/mGear/tools/mgear_4.0.7/

1 Like

This worked for me

2 Likes

OMG! Thank you, thank you, thank you. It works! Finally, you are awesome. I can’t thank you enough.