Home Website Youtube GitHub

mGear not working in Maya Creative 2023?

Hello there!

I’ve been working with Maya Creative 2023 for a couple of months now, and it’s been a good run so far. Yesterday I was sent a rig with mGear features, so I tried to install the tool and couldn’t make it work for the life of me. I tried every solution I could find (I’m not a tech guy but I tried my best) but still wasn’t running.

From what I got, I think the problem was that the program couldn’t properly load the .dll files. None of them would appear in the plug-in manager and, when trying to add them manually, an error would appear in the script editor saying that “the file doesn’t have a valid digital signature” (or something to that effect).

We decided to install standard Maya (2023) and try it there and it gave me no issues at all, so I guess it’s something to do with Maya Creative? I don’t know if anybody else has had this problem before (I haven’t found anything on the Internet about it) so maybe it’s just me, or maybe mGear just doesn’t work on Maya Creative. If so, are there any plans to fix it? Am I doing something wrong?

Thanks for the help!

Hi there,

Unfortunately no. The most affordable compatible license I know would be Maya Indie.

A quick look at the product page for Maya Creative shows two things you need, which you can’t install:

  • PyMel
  • Load third-party plug-ins and tools (Pretty much the only thing that makes Maya worth it, no? :frowning: )

1 Like