Home Youtube GitHub

Nurbs Controls Glitch


#1

Hi everyone,

Anyone seen this kind of thing happening before?

The nurbs control becomes like that after I enter and exit isolate selection mode, it happens quite often, I am not sure if it’s because of my graphic card, Maya 2019 or mGear…

I would have to save and reopen the Maya scene every time it happens, and if I don’t use Isolate selection but using display layers to hide the controls, it won’t trigger the glitch.


#2

I have seen this before. If I scrub the timeline the nurbs curves refresh to normal. Think its a viewport issue.


#3

There are a lot of issues with Maya and parallel evaluation. Sometimes if you hide your geometry, when you make it visible again, it can stop following the rig properly. I wonder if this nurbs curve problem is a bit similar. I’ve never seen it happen on curves though. (I haven’t tested 2019 very much yet.)

If you turn parallel evaluation to DG, or turn GPU override off and then back on again, does it make a difference? (That is not the fix, just the way to diagnose the problem.)


#4

Scrubbing the timeline doesn’t seem to do anything though…

But when I turn parallel evaluation to DG, the problem got fixed. I got to save the preferences and save the file and reopen it for it to take effect. Just changing that option do nothing unless I save and reopen.

I also tried turning GPU override on and off… nothing happens, glitch still there, and if I save preferences and the maya scene and then reopen it, glitch still happens when I do the isolate selection.

I will turn parallel evaluation off for now, that seems to work for me, thanks Chris for helping out and also Toke too for the tip :grinning:


#5

I’m always getting this one.


#6

Is it only on Maya 2019?


#7

When I did some testing in 2019 I had problems like this with some stock shape nodes and all custom shape nodes. dgdirty -a fixes it but it’s not a viable long term solution.


#8

Thanks for the tip! I will try that