Website Youtube GitHub

mGear Framework Forum

Object Missing error during rig Build

I’m using Maya 2017 and mGear 3.4

I just installed it and tried playing around. I followed the tutorial to make a rig from scratch with Shifter. When I build from selection this is the message I get.

GEAR version : 3.4.0

= SHIFTER RIG SYSTEM ==============================================

= GUIDE VALIDATION ==============================================
Checking guide
Get options
Get controllers
Get components
Local_C0 (control_01)
COG_C0 (control_01)
COG_C1 (control_01)
leg_L0 (leg_2jnt_01)
uiLeg_L0 (control_01)
Object missing : foot_L0_heel
Object missing : foot_L0_outpivot
Object missing : foot_L0_inpivot
foot_L0 (foot_bk_01)
spine_C0 (spine_ik_01)
neck_C0 (neck_ik_01)
shoulder_L0 (shoulder_01)
arm_L0 (arm_2jnt_01)
shoulder_R0 (shoulder_01)
arm_R0 (arm_2jnt_01)
leg_R0 (leg_2jnt_01)
Object missing : foot_R0_heel
Object missing : foot_R0_outpivot
Object missing : foot_R0_inpivot
foot_R0 (foot_bk_01)
Find recursive in [ 0:00:00.568729 ]
The guide doesn’t seem to be up to date.Check logged messages and update the guide.
Guide loaded from hierarchy in [ 0:00:00.569088 ]

I tried updating the guides but Then I get a runtime error.

Error: RuntimeError: file /Applications/Autodesk/maya2017/Maya.app/Contents/Frameworks/Python.framework/Versions/Current/lib/python2.7/site-packages/pymel/internal/pmcmds.py line 134: Unable to create/find dependency node.

I’m not sure if it’s a Maya issue or mGear issue, but either way I’m missing the rest of the foot.
Any Suggestions?

Hello @goofball851

can you share the guide? Maybe is something missing.

Thanks

Here’s a screenshot of what it looks like. In the tutorials there are three parts on the back of the red controller, but I get nothing. I even tried installing the previous version but nothing changed.

Ah…

Actually it was a plugin error with my directories. it was listed in the script editor

2 Likes

I was having the Dependencies error in maya 2019. When I opened up the plugin window, the mgear solver was off. Turning it on solved this issue for me.