Home Youtube GitHub

Problema building rig from selection v3.1


#1

Hi,

I’m using mGear v3.1 (the latest) and I have imported the guide template sample of the quadroped. When I select the guide group in the outliner and hit Build from Selection I get very funky and random results. Sometimes it builds it, sometimes it doesn’t, sometimes only parts of it and often parts aren’t linked up correctly like IK handles etc.

I’m using maya 2018.4.

Has anyone else had this issue? Any ideas?

Callum


#2

Try to open the guide file in Shifter Guide Manager and build from there. Usually I save all my modificiations in guides as a template, and then open this file in the Manager. It always gives me better results in the builds.


#3

Thanks for the reply Sam.
I tried it but no luck… Surely the default biped and quadroped should be able to build just fine? Previous versions of mGear worked fine for me so I will try an older version.


#4

Hello @Callum_Austin

Can you please try your install version of mGear inside another Maya version to see if you get the same results?


#5

I just tried different version of mgear and they’re all having the same problem now. I can’t seem to get the installation to work properly. mGear loads and shows up in the menu and im able to create guides, but the rigs simply don’t work. I think i’m doing something wrong in terms of installation and loading plug-ins… really struggling with this one…

It worked fine with this version of Maya before so I think that should be fine… i dont really want to change maya version :confused:


#6

Hi,

I’m also getting this error when our production changed the operating system from centOS to openSuse. I’m getting these two error reports when I try to build a rig.

Error: line 1: ImportError: file /usr/autodesk/maya2018/lib/python27.zip/md5.py line 10: cannot import name md5

Error: line 1: AttributeError: file /usr/autodesk/maya2018/lib/python2.7/site-packages/pymel/util/objectParser.py line 593: ‘NoneType’ object has no attribute ‘parse’

I’m really confused because of this & requested my production to switch me back to centOS. Already built rigs work fine in openSuse but I cant build from guides.


#7

@niteshms04 Never used OpenSuse, and to be honest has been more than 2 years that not using CentOS or any other Linux distro
I hope someone else can help here :frowning:


#8

Thanks Miquel. I’ll see if I can find a solution. Is there an installation video for the latest mgear? Im working on a server with a lot of env variables already setup.


#9

@Callum_Austin Nop sorry, no new videos on installation. But nothing has change, so old video still good.