Website Youtube GitHub

mGear Framework Forum

Quadruped feet rotate inside Unreal Engine with no rotation keys set

Hi!

I’m having an issue with only the front quadruped legs. When working inside Maya there are no rotation keys set, but when I move the animation inside Unreal Engine, the feet rotate. I am unsure what is causing this and it has shown through a few other rigs I built as well with mgear. I also tried it on the pig rig (https://gumroad.com/l/bmnPI) to test and see if maybe the way I built mine was incorrect, but I had the same issue with someone else’s rig. Any advice/suggestions would be wonderful.

Thanks!

fq14C3LGet — I’m unsure why the gif loaded so tiny

could be a fbx/shearing issue maybe? have you tried building your rig with force uniform scaling on?

edit: i had that same gif issue when i tried to upload one yesterday :stuck_out_tongue:

Maybe! I don’t know how to turn on uniform scaling, but I can test that and see if that is what is causing the issue

its a setting on the guide root

Thank you! I will try that out and post back later if it worked

Maybe @Milio can help with this one? :slight_smile:

1 Like

Okay! I just tried doing the force uniform scaling and it made the feet move inside of Maya now as well instead of it all staying still. So it doesn’t seem like fixed the issue :frowning: Thank you though!

It may not have “fixed” it, but it made it visible to you in Maya. So now maybe it will make it easier to find out why it is happening?

2 Likes

hellooo! that’s pretty strange behaviour! The only “issue” I found using the hind leg is the re-parenting of extra controls placed along the leg, but nothing wrong on the functionality of the leg itself. I’ll check later my pig guide and will check. Maybe is a good idea including mGear guides along with the rigs, so people can have a look at how my rigs got solved.

1 Like

I didnt export the pig into Unreal but I have found though several severe gimbal problems in a couple of rigs, especially in Wayne Batman one. Arms and the bones i use for in-game squash/stretch head were terribly affected by odd rotations during the animation. I ended up giving up… couldnt fix the issue!!


There’s something that sort of fixed the issue, but was altering the original animatio : preserve local transform. Try out if ticking that option on fix the problem.

Cheers

3 Likes

Preserve Local Transform The way the engine calculates and accumulates transforms is different. We calculate the global transform and then calculate back to the local transform. In some cases, this can affect animations using 3DS Max or non-uniform scale.


this is what i had in unreal, I ended up exporting alembics…8-o

2 Likes

Thank you for the reply and advice! I tried turning on “preserve local transform” and it looks like it has fixed the unwanted movement issue with the feet on my end :+1:

2 Likes

Great! but careful!! double-check the integrity of the animation is 100% as in Maya side. I thought the issue was fixed, but although similar, the animation changed slightly.

I have tried to export the my pig rig, and as you can see in the video, there’s some gimbal issues in the front left paw…

1 Like

ummmm. I’ll try to re-export the animation again. The animation was done as a skinning test during the rigging process, eventually, the rig changed to the last version upload in Gumroad. Might be something is not in synch between the bind pose and the animation.

Nop, same issue even with the same bind pose/animation exported. If you watch the video, you can see how the first pose changes every time I re-import the animation changing the preserve local transformation. I exported all this using Maya 2019.3.1 from the game exporter tool. I have no idea how to fix this issue, I double-checked joints axis are correct by importing the fbx back to maya, nothing strange is happening, no odd rotations, axis are consistent. My understanding is that is at Unreal end where is getting broken, the way the bones are getting solved although the animation is sampled by 1 is not, sometimes accurate enough. I’ll carry on investigating…

ummmm it is definitely that end joint the one with gimbal issues…how necessary it is? maybe just deleting it once the rig is built could solve the problem?

update: deleting the end joint fixed the problem, but still some other joints are rotating wrongly…this makes no sense at all…the end joint deleted contained a lot of micro non-uniform scaling, but the chest bone is just the end of the chain bone, it shouldn’t do anything odd… definitely something strange is going on…

that bone , chest HAS NO animation and is rotating crazy in unreal… _

new update: i cant post more than 3 times in a row! haha!

is it because of that??? not converting the scene is fixing the odd rotation on the chest joint…obviously the animation is flipped and fucked up…but rotation is sorted…

latest update: think it might be fixed…the issue is the Unreal convert scene turned on… import the asset again rotating x to 90 and voila! no more rotations! I think instead the ugly x to 90 it could work by exporting Z up in fbx options… ill try tomorrow!

carrying on with my ranting: tried to export z up + no convert scene didn’t fix the issue.
I tried though, importing into unreal ticking on the convert scene plus forcing front x and magically all gimbal are fixed…but the animation is now facing x, not matching with Maya orientation ! but that is fixable importing with z 90…
image|574x500
however, some gimbals are fixed…but some others, like in the arm twister are happening…i don’t really know how to keep this consistent… 8-(

1 Like

I double checked some of the animations with that setting turned on and I haven’t noticed anything out of place. I will make sure to keep an eye on it though!