Home Youtube GitHub

RBF Manager issue


#1

Hi, i’m new to mgear and i’m making simple rigs myself. Unfortunately i cannot in any way make the RBF Manager to work with my custom rig (not mgear). I watched the video many many times but it doesn’t help. The issue is that no matter what i do but the on every new pose the driven poses are all empty (zeroes).
I see that even with a scene with only 2 objects (and their respective controller) doesn’t work because of how the node is added (after the WD_trfm is added the channels are no longer tweakable). There must be some way to make this work outside mgear where obviously it works.

Help me please to implement this awesome tool into my pipeline.

-elvis


#2

Hi @elvis75k

Can you try adding a parent transform to the control? is what I call in mgear “neutral pose” node, so the channels of your control are reset.


#3

Ok, now the driver is working (per pose channels get populated with correct values) but there’s something obvious that i miss: say that the driven object is a sphere in a group of other objects: when i create a new rbf node the sphere get parented under a new group named sphere_driven_WD_trfm… NOW: i cannot transform this new group because it is driven and transforming the sphere itself does not send the values when the next pose is added.

Is there something that i need to do to the driven object also to keep going?

Thanks


#4

To add the poses you have to manipulate the sphere. Then the values in the sphere will be reset when the new pose is added.


#5

Will you be so kind to share a simple sample scene? I really can’t make this to work. I’m going mad.
Thanks


#6

I think that i found the source of my troubles and it is not related to constrains or zeroed out values… instead everything is working when using the mgear standard names for the driver and the driven. Please explain why the 1st line is ok and the 2nd is not

arm_L0_ikcns_ctl - can drive - arm_L2_ikcns_ctl
arm_L0_ikcns_ctl - cant’t drive - arm_L2_ikcns_ct


#7

Hey @elvis75k Sorry to hear about your troubles with the RBF Manager.

I think what might get you through the issue of recording or creating poses, is naming the desired driven object [something]_ctl
The the tool is looking for something with that suffix so it can parent a group above it and push/pull values to that node, leaving your [something]_ctl open for posing.

Then when you are done, you can rename the control whatever you want, or adopt that naming convention, should it fit your needs.

Let me know if that helps!


#8

Thanks @Rafael for your detailed info. It works now :slight_smile:


#9

Hello,
I think I’m facing the same issue.
Tried to rename my custom rig controls to match mgear names. But when I add a pose, it’s not storing the data from the controller.

Could you please try to help me what am doing wrong?


#10

Any chance here? Still can not figure out what I’m doing wrong


#11

add the _ctl suffix to the driven… that’s the hint. I can’t help you right now, anyway i have probably backed up the working scene, i’ll be back tomorrow.


#12

thanks is working now.