Home Website Youtube GitHub

Sdk_io export issue


When i try to export the driven keys from a blendShape node I’m getting this error. I tried doing this for object to object driven key and even that is giving the same error.

Also can some one suggest me a method to connect with blendShapes instead of driven keys. I tried Rbf manager but it wont import once the poses are set for the blendshapes during the post custom scripts.


Hey niteshms04,

The export command expects the first argument to be a list of nodes to export.
If you use [sel] instead of sel as an argument, it should work :slight_smile:.

1 Like


when I do that i.e [sel], I’m getting a list index out of range error


Could you try again with Stack trace turned on in the script editor? It’s under History.
Might give some more information. Otherwise if we could have an example scene to debug, would be very helpful :slight_smile:


1 Like


Sorry for the late response but this issue happens only when its a blendShape node. For every thing else it works absolutely fine.

Thanks for helping me out


No problem,

Would be a nice bug report to keep track of on Github.

I’ll have to try this out myself to see if I can reproduce it and add the bug report :slight_smile:.


I am digging up this necro thread because I ran into the same issue when trying to export my SDK setup for blendshapes.

To fix this you can add the ‘blendShape’ to the exported types:

# sdk_io, line 118
connectionTypes = [SDK_UTILITY_TYPE[0], "transform", "blendShape"]
1 Like