Home Website Youtube GitHub

Separated Joint Structure Bug - SOLVED

Driving me nuts. So I would save out a guide. Bring it back in, and it would keep giving me those damn separated joint structures which I really hate. Did the forum and youtubes. Looks like there’s an issue w/ Separated Joint Structure and the Attribute Editor updating. The weirder thing is I could only get proper, game friendly joint structures when I would UNCHECK Separated Joint Structures and CHECK ON Joint Rig even though as you can see in the gif one checks the other off. Can we see if that’s some dumb user error on my part or just a bug. I don’t know why the name change from Separated Joint Structure to Joint Rig so I’m assuming they’re different and parity just falls off here?

trying to keep it gify JointRigGoodSeparatedJointsBad

Looks like you marked this as “SOLVED”, but what issue are you referring to? It would help if you provided a link.

It is the same attribute. They just have different names. The attribute editor is the attribute. The GUI one is the user-facing interface you use to edit the attribute. Attribute names are shorter. GUI names are longer and more descriptive. You can’t have one off and the other on. If you edit the attribute directly from the attribute editor, you have to refresh the GUI to see the change in the GUI. The state of the attribute in the attribute editor is what gets read when you build the rig.

Well, I don’t know that. But it doesn’t really matter what the default is. You should choose the settings that work for your situation. I assume most of the default settings are choices that Miquel used in the many years of production in which he developed these tools. These tools weren’t originally built for games, though more and more game-friendly tools are being added in, especially as many non-game productions are adopting Unreal too. (My opinion and perspective, not an official answer.)