Website Youtube GitHub

mGear Framework Forum

Softtweaks "add object to selected tweak" performance slowdown

Hi
I love the softtweaks as a rigging add-on. I encounter serious performance issues, however, in the following setup:
I have two skinned meshes (medium and highres). Both are skinned and give massive fps (yay!). I apply softtweaks to one mesh, which still performs very good after doing so. When all setup, I use in the softtweaks window “add object to selected tweak”, to add the other mesh. Now the framerate drops dramatically, to around 1.5 fps.
The order of setting up/adding meshes doesn’t seem to matter to cause the framedrop. When I apply the softtweak to both meshes at the same time, the performance is still great. So, can it be that the “add object to selected tweak” command hooks up the softmods wrongfully, and therefore is killing performance?
I like to use this function, otherwise I have to redo the whole bunch when meshes are updated

Also, btw, when I disconnect, or entirely delete the second skin, the whole scene still keeps bugging down in framerate. As if some connections still are being calculated, though not present anymore

What else is in your history stack on your geo? Have you tried using the profiler to see what is causing the slow-down?

What does “delete the second skin” mean exactly? Are you deleting the entire history on the 2nd geo to try and remove it from the softMod? Or deleting the entire geo? If you delete the softTweak, does the scene speed back up?

Are you willing to share your scene that already has the slow-down that can be tested?

Hey Chris, thank you for your time. I PM-ed you a file in which two skins, both affected by the same softtweaks, slow everything down. There indeed the case seems to be as follows: If I detach the ST’s from either mesh it still slows down. When plain deleting the mesh, all is fine again.
To make it weirder, sometimes, when I juggle with deleting the ST’s after exporting them out, then re-importing them again and attaching the meshes to them again, I do get proper performance. I don’t know if that’s the case on every machine, but for good measure, I’ll pm you that file as well.
The profiler does not give me a clou what is, or isn’t causing the drop

(First, if anyone joins in to help, I recommend importing his files instead of opening them. I opened the files and they caused my preferences to glitch out with this error. @mackerB think something might be wrong with your prefs layout, but that has nothing to do with this problem. Do you see a selCom error when you select things in the Outliner?)

Sorry, this is beyond me. I have no idea what’s going on. I looked at your 2 versions of the file. They both have many softMods (around 15 or so).

The slow version of the file has all of the softMods evaluating cumulatively. So each new one seems to calculate longer than the last. And this is what it looks like. All the stacked green bars are the softMods.

In the other version of the file, the softMods are still there, and still working, but those green bars don’t show up, the parallel eval stacks cleanly, and the rig evaluates quickly. I can’t see any structural difference in the rigs.

I noticed a weird bug where if I use the “Add Obj to Selected Tweak”, it changes the shape (offsets the falloff position) of the softMod.

@mackerB A workaround that worked for me, and should work for you, is to simply use the Relationship Editor to add your 2nd geo to the softMod deformer.

Here is a gif of the offset happening. The higher bulge is the old shape, and then when I add the 2nd geo, it offsets down in position and smaller in size. I haven’t investigated how the connections change yet.
offsettweaks

@chrislesage thanks for checking this. I am following this thread , let me know if this is a bug. I will open a new ticket in github :slight_smile:
Thanks!!

Hey @chrislesage and @Miquel, thanks for checking it out.
At first , the selCom-error suddenly appeared at my side. No idea what causes it. Sorry for passing it through, did not know it traveled with the file.
Second, very strange how Maya evaluates differently files which seem to be build up the same way. It boggles the mind. Maybe that manual hookup will do the trick, also performance-wise. I can’t figure out however how to custom connect the softmod to the skincluster. The node-editor doesn’t show me a connection between the two which would explain that to me. Could you maybe tell me which in and out to connect?

Cheers

What does “custom connect the softmod to the skincluster.” mean?

If you are trying to do what I said, it isn’t a node editor connection. Use the “Relationship Editor”. Select the softMod set on the left side. Select the geometry on the right side.

I am indeed trying to do what you said, indeed. If I connect the softmod directly to the geo, wouldn’t that overrule the skincluster? Shouldn’t the softmod and the skincluster get connected?

…no?

A softMod is a geometry deformer. If you find a way to connect it to the skinCluster, please write us a tutorial. :wink:

1 Like