Home Website Youtube GitHub

SOLVED: Has the 'rigbits.facial_rigger.eye_rigger.rig_from_file(eyesConfigPath) module changed?

Last week I was making a Post script with the ‘rigbits.facial_rigger.eye_rigger.rig_from_file(eyesConfigPath)’ shown here on the workflow page,
http://www.mgear-framework.com/mgear_dist/official-unofficial-workflow.html

It’s saying to use the newer method of building eye rigs. I was using it and all was well, building the eye rig perfectly. Now I open it up Monday morning to show to my animators and it crashes with the error.

File “F:/NianticPerforce/Creatures/Creature01/Rig/Data/mGear/PostScript_AddEyesVolumeReference.py”, line 22, in
rigbits.facial_rigger.eye_rigger.rig_from_file(l_eyePath)
AttributeError: ‘module’ object has no attribute ‘facial_rigger’

I know it was working last week, has the internal library changed? Where is the documentation if so? I’ll attach my small py file to for anyone who is interested.

Hello @gwall
There were some changes with the latest release. But should work with previous configurations. I am also using it in production and didn’t have any issues.

Checking the way you import the module I get the same error. But the way I import is working

# THIS WILL FAIL
from mgear import rigbits
a = rigbits.facial_rigger.eye_rigger.rig_from_file

# THIS WORKS
from mgear.rigbits.facial_rigger import eye_rigger
a = eye_rigger.rig_from_file

Can you try to change the import line?

1 Like

Hi Miquel,

I tried this way of importing and it worked, thank you very much for taking the time! So was I looking in the wrong place or not understand the example that was in the ‘Rigging Workflow’ page regarding the eye/lip module?

thanks for pointing this out. I will update the documentation to reflect this.