Home Website Youtube GitHub

[SOLVED] Missing inbetween joints

What is causing the builder to build rigs differently depending on the scene?
I have a guide scene where it doesnt build inbetween joints and only connects the root joint of each component to eachother. However in another scene with similar setup it connects joints correctly and with inbetween joints. exporting the “broken” guides to a template and importing to a new scene yields the same results and the original scene. Pictures and scene files are below

main guide scene

only root joints connect

a new guide scene with similar setup


The “easy” solution would probably be to create an entirely new rig scene and build the guides again. But i would like to now what could be causing this to happen so I can avoid it next time.
Thank you in advance! :smiley:

Silly me had changed the naming rules to a faulty combination:
Changing the joints naming rule from “component” to “description” worked.
Ill leave this post up with my solution in case anyone else does something as silly.

1 Like