Home Website Youtube GitHub

SOLVED: Rig build issue with Mgear 3.7 and Maya 202.2


when testing i tried to build from the guide sample-Biped but i get this error-

Error: RuntimeError: file C:\Users\Actor\Documents\maya\modules\scripts\mgear\core\utils.py line 223: Unable to create/find dependency node.

Any ideas?

Thank you

is only this error line? it is not useful to debug, just pointing to a timer wrap function
the mgear_solvers are loaded?

hello Miquel.

I got the same error too.

Maya version is 2020.4. with mgear 3.4.
It worked fine with Maya 2019.

Here is the err message. thank you!

#   File "C:\Program Files\Autodesk\Maya2020\Python\lib\site-packages\pymel\internal\factories.py", line 830, in callback
#     res = origCallback(*newargs)
#   File "C:/Users/xxxxxx/Documents/maya/scripts\mgear\shifter\io.py", line 210, in import_sample_template
#     import_guide_template(path)
#   File "C:/Users/xxxxxx/Documents/maya/scripts\mgear\shifter\io.py", line 176, in import_guide_template
#     import_partial_guide(filePath, conf=conf)
#   File "C:/Users/xxxxxx/Documents/maya/scripts\mgear\shifter\io.py", line 140, in import_partial_guide
#     partial_names, partial_idx = rig.guide.draw_guide(partial, initParent)
#   File "C:/Users/xxxxxx/Documents/maya/scripts\mgear\core\utils.py", line 223, in wrap
#     raise e
# RuntimeError: Unable to create/find dependency node. #

Hello @snake
the error is just building the default biped guide after import in a new scene?
Can you send me the scene? Just to be sure. We are using Maya 2020.3 at the studio and I didn have any issues.
I think I can update to 2020.4 in my laptop to be sure is nothing related to Maya version.

hello Miquel

yes it was imported on new scene.
I tried mgear 3.7 and it resulted the same.

And I got this when trying to draw cable_01(or other component).

thank you!

スクリーンショット 2021-05-17 104532

# Traceback (most recent call last):
#   File "C:/Users/Fuksang.Seah/Documents/maya/scripts\mgear\shifter\guide_manager_component.py", line 238, in draw_comp_doubleClick
#     self.draw_component()
#   File "C:/Users/Fuksang.Seah/Documents/maya/scripts\mgear\shifter\guide_manager_component.py", line 252, in draw_component
#     guide_manager.draw_comp(x.data(), parent, showUI)
#   File "C:/Users/Fuksang.Seah/Documents/maya/scripts\mgear\shifter\guide_manager.py", line 32, in draw_comp
#     guide.drawNewComponent(parent, comp_type, showUI)
#   File "C:/Users/Fuksang.Seah/Documents/maya/scripts\mgear\shifter\guide.py", line 718, in drawNewComponent
#     comp_guide.drawFromUI(parent, showUI)
#   File "C:/Users/Fuksang.Seah/Documents/maya/scripts\mgear\shifter\component\guide.py", line 407, in drawFromUI
#     self.draw(parent)
#   File "C:/Users/Fuksang.Seah/Documents/maya/scripts\mgear\shifter\component\guide.py", line 388, in draw
#     self.addObjects()
#   File "C:/Users/Fuksang.Seah/Documents/maya/scripts/mgear/shifter_classic_components\cable_01\guide.py", line 70, in addObjects
#     self.dispcrv = self.addDispCurve("crv", centers, 3)
#   File "C:/Users/Fuksang.Seah/Documents/maya/scripts\mgear\shifter\component\guide.py", line 739, in addDispCurve
#     degree)
#   File "C:/Users/Fuksang.Seah/Documents/maya/scripts\mgear\core\icon.py", line 1024, in connection_display_curve
#     crv = curve.addCnsCurve(centers[0], name, centers, degree)
#   File "C:/Users/Fuksang.Seah/Documents/maya/scripts\mgear\core\curve.py", line 50, in addCnsCurve
#     applyop.gear_curvecns_op(node, centers)
#   File "C:/Users/Fuksang.Seah/Documents/maya/scripts\mgear\core\applyop.py", line 474, in gear_curvecns_op
#     node = pm.deformer(type="mgear_curveCns")[0]
#   File "C:\Program Files\Autodesk\Maya2020\Python\lib\site-packages\pymel\core\animation.py", line 56, in deformer
#     return map(_general.PyNode, cmds.deformer(*args, **kwargs))
#   File "C:\Program Files\Autodesk\Maya2020\Python\lib\site-packages\pymel\internal\pmcmds.py", line 130, in deformer_wrapped
#     res = new_cmd(*new_args, **new_kwargs)
# RuntimeError: Unable to create/find dependency node.

can you confirm that you have the mgear_solvers.mll load in the plugin manager?

hello Miquel

Sorry I forgot to check the plugin path.
It works now.

thanks for the help!