Website Youtube GitHub

Some errors in brows rigger


#1

Hello my name is Yohei.
I started to using mGear last year.
Now I am trying to use brows rigger, but having some errors.

First, I selected some edges like this
image
brows rigger settings are below.


when I bulid browrigger , I got error below.

File “C:\Users\username\mgear\maya\3.3.1\scripts\mgear\rigbits\facial_rigger\brow_rigger.py”, line 1524, in build_rig

rig(**lib.get_settings_from_widget(self))

File “C:\Users\username\mgear\rigbits\facial_rigger\brow_rigger.py”, line 126, in rig

mid_loop_len = len(mid_loop)

TypeError: object of type ‘NoneType’ has no len()

Next, I tried to build without symmentry mode
I selected only left side edges and changes settings below
image
This time build successed.
Then I tried to bulid right side.select right side edges and changed settings below.
image
When I tried to build, I got error below

Warning: Too many coincident knots. Maximum allowed is degree

Traceback (most recent call last):

File “C:\Users\username\mgear\rigbits\facial_rigger\brow_rigger.py”, line 1524, in build_rig

rig(**lib.get_settings_from_widget(self))

File “C:\Users\username\mgear\rigbits\facial_rigger\brow_rigger.py”, line 764, in rig

tag_parent = parent_tag_R

UnboundLocalError: local variable ‘parent_tag_R’ referenced before assignment

Could you tell me where is wrong to use brows rigger?
Sorry for my broken English.


#2

can you try with another edge loop?
Just to be sure is not related with the 5 edges vertex

image


#3

Thank you for replay.

I tried another edge loop like this
image
This time there was no error, but result is strange.
Both left and right brow joints were placed from left to right.
And center brow joints was not created.
image


#4

I changed edge loop selection only left side.
image
Build was succes, but center brow was still not build.
image


#5

I realized edge loop order in brows rigger UI is different from selection.
The number of edge which is selected first is [2109], but strings in UI Brow Edge Loop started from [1123].
image
I changed strings in UI to [2019] come to first.
image
Then I tried to build. It was success!
image


#6

interesting finding! Can you check your maya preferences?
image


#7

Yes, I checked.
Track selection order does not effect to the order in UI.


#8

to be honest. Not sure why is not sorting correctly the edge order. I will do some test again, but for the moment I can’t reproduce this error


#9

I guess something is wrong in my model.
But for now I can avoid error with method which I wrote.
Thank you for your effort so much!!


#10

Sometimes I’m creating temporary geometry just for brows / eyes / lips. Which sometimes helps with issues like these and allow to control joints positions a bit more.

Could you please share the model, I’d like to check if where is the issue as it’s working just fine after testing on our models.


#11

Are you using a Wacom tablet or a mouse?

There is a very strange bug where selecting things with a Wacom tablet produces a different and incorrect selection order of nodes in the Outliner. In the Outliner, if you shift select nodes from bottom to top, the order will be incorrect. That doesn’t happen with a mouse!

(If that bug exists for edge components, I’m not sure. I’ve only seen it with nodes.)


#12

Thank you for your offer.
This is file download link
https://www.datadeliver.net/receiver/file_box.do?rc=882fc565595e41cdacd3c1dad5c936b3&fb=4ff149e6b8b9424591e8e9d7c1e09ce2&lang=ja&submit.x=38&submit.y=7


#13

I use 3dconnection’s wirress mouse.
I have never heard about wacom’s issue.
I will be carefull for selection order in outliner.


#14

@yohei thank you for the files. I’ve checked the mesh and indeed there is an issue - not 100% sure, but it might be just mesh related. I’ve tested the script on my test scene and it’s working pretty well, also managed to build a correct rig on your scene.

First of all, It would work if you do not have a poly flow, so try to avoid building on areas like these:


As you will run into issues like that:

But other loops should be working just fine, as the results:

My test scene:


As you can see there was no issue to build the rig multiple times.

Your scene is a bit weird, as on an edge that is should be just fine it’s not working, but the edge that is above it is just fine. I even tried to separate that mesh, but the same results.

testCase_01
this is good, but a loop below:


testCase_04

Did a quick check for edges ID

and it seems fine, but just in case I’ve changed the order:

fixed2

I did not have time for bigger research right now, but there is an issue with detecting mid-segment edges on your mesh. Changing the vertex order seems to fix that, but I do not understand why.

Hopes it helps somehow
Cheers,
K


#15

Thank you for your detailed research!
I think it will help me.