Home Website Youtube GitHub

Space Transfer Errors


I am currently creating an animation.
So I tried to convert an animation keyed to FK to IK using mGear’s Space Transfer feature, but this tool does not seem to work. Here is the error log.

# Traceback (most recent call last):
#   File "C:\Users\tanaka\Documents\maya\2020\plug-ins\mgear4.0.9\release\scripts\mgear\core\anim_utils.py", line 2006, in doItByUI
#     self.transfer(startFrame, endFrame, onlyKeyframes, self.hasIkRot)
#   File "C:\Users\tanaka\Documents\maya\2020\plug-ins\mgear4.0.9\release\scripts\mgear\core\anim_utils.py", line 1992, in transfer
#     definition,
#   File "C:\Users\tanaka\Documents\maya\2020\plug-ins\mgear4.0.9\release\scripts\mgear\core\utils.py", line 214, in wrap
#     raise e
# RuntimeError: paneLayout: Object '0' not found.

Do you know what is causing this Space Transfer error?

@tanata Sorry I can’t reproduce the error. I have tried with the default biped.
Can you provide more information or a sample scene? Thanks

I am very happy to hear back from you.

Sorry for the lack of information last time.

I have prepared sample data this time. (I have a rig with built guides and guides in Maya scene and simple animations on arm L, R.)

I created a simple scene this time and then used Space Transfer to create the animation on the FK controller and when I converted it to IK this functionality seemed to work fine.

When the above error occurred, it occurred when I launched the Studio launcher, and I assumed that perhaps Space Transfer was conflicting with another python module, causing the error.

This may need to be resolved in-house, but if there is a workaround in case of a conflict with another module, I would appreciate it if you could let me know.

Below are the Maya Version and mGear Version at the time I created my sample scene.

Maya Version:
Maya 2020.4

mGear Version:

Thank you very much.