Website Youtube GitHub

Spine & Neck Max Stretch issues - need help please


Hi Tsahi,

Yeah wow that is some strange behaviour.

What do you mean by “a head squash”? What is it exactly?

Are you willing and able to share the file for me to look at?


Thanks for replying Chris.

I’m on mGear 3.2.
I experienced this weirdness in more than one character, all started from biped template.
I added a squash_01 component to the head under neck_C0_head.
But as you can see in the second video link I posed, it happens even without that squash.
I’ll send you the file in a private message (hope that’s possible). Please don’t share it with others or create other things from it.
I’m a bit afraid of rebuilding as I ran into some errors with some of the brow/face rigs custom steps,
and I also added corrective blendshapes with SHAPES, with no custom step yet.

Thank you very much!


To whoever is reading along, we looked at this, and it seems to be a problem with Maya 2019. The rig works fine in Maya 2018, but acts weird in Maya 2019, with or without the squash_01 component and with or without the SHAPES plugin.

No idea if this is an mGear or Maya issue.

(Another reason I’m glad I’ve stuck with Maya 2018.5 for now.)


Quick question @Tsahi

Does your skinning in Maya 2019 defaults to DualQuaternium when applying?
@chrislesage you actually opened the buggy file inside Maya 2018 and everythging was fine?


Good call. It is using DQ weights, and turning if off fixes the weird backwards flipping effect.

However, there is still some weird skewing occurring even with Linear weights in Maya 2019.

Yes, I opened it in Maya 2018 and it works fine (MacOS and Windows)


If I may have the Maya file (2019 save) I can try to see if this is a mgear node issue related to compiling with Maya 2019. (again this is for debugging, can’t really promise right away if this is “fixable or not”) I do recommend trying the same file with Maya 2019.2


Yep. @Tsahi I took the liberty of sharing the file with Jerome.


@Jerome The skin default wasn’t DQ, it was classic linear.
When I added the face rigger I switche it to DQ to get proper eyelid deformation around the eyes.

On second thought, I did export and import the skin at some point, so it probably got reskinned as DQ.

Chris passed you the file. This is in production now and I have the authority to share it with support.
Just so please don’t share it with anyone or use it publicly or commercially for anything else.



Hello guys

This indeed seems to be more problematic than I though. I will be running some tests tonight and will try to find a solution for this.


I am still loocking into this. Yesterday I checked some of the mGear solvers from 2018 and 2019 but so far I haven’t been able to pin point what is exactly causing the problem .


Hi @Tsahi @Jerome @chrislesage

I am following the thread. If you don’t find the solution please send me the data, I am also interested to know the source of this issue.



Hello @Tsahi @Miquel @chrislesage

So I have one tiny good news, and one big bad news.

  • The good news is that I found what is going on… yay
  • The bad news is that the bug is a Maya 2019 bug.

@Tsahi basically Maya 2019 shear attribute on the joints is not doing anything any more so mgears stretch/squash build-in system won’t work… I am quite shock about this I must admit…

I submitted the bug to Autodesk just now with a little video description.

@Tsahi Now for a solution. Basically because the joints shear attribute doesn’t work trying to by-passed it on the joint itself won’t work so what you need to do is that for each skin joint that has connections to the shear attributes you create a transform node (group) on top of the joint an connect the shear attributes into that group rather than the joints. This will solve the problem. If I have the time I will send you a code snipped for this.

Cheers and sorry for the bad news.

PS: I log every year more than 10 bugs to Autodesk and I see them often all been taken care of but the problem is always waiting for the release update and they just did one for Maya 2019 (2019.2) so my guess is that this won’t get solved till end of the year :frowning:


Nice work Jerome!

Disappointing but unsurprising. (I’m not shocked.) That is why studios should be slow and cautious to upgrade Maya.


Thanks @Jerome for the research on this. I can’t believe this kind of things happen in the most basic things in each Maya release :triumph:


Very nice work @Jerome and thanks for taking the time to research this.
In the mean time I reverted to an older version, so I guess I’ll just stick with that for now to avoid more unexpected issues, and also due to time constraints.
If you do create a code snippet for it, please post it here.

Thank you all for being so responsive and supportive.


@Tsahi not sure if you tried this. But since the issue is related with the shear, can you try to build the rig checking Force uniform scaling?

please let me know if this helps.



That seems to solve the problem for me for new rig builds, thanks!


I will test it to see if this solves it.
But I have some issues with post custom scripts, and I’m not very well versed with Python,
so I’m not sure I’ll rebuild the final character again.

Thanks Miguel!


Another option is to create a simple script to run over the rig and change the connections. If I have a little time I will do it. (But can’t promise anything )

NOTE: that maybe the deformation change a little when you do squash and stretch.


I ran a quick test with “force uniform scaling” on and it looks like it works for the spine stretch issues.
Thanks Miguel.