Home Youtube GitHub

Statesman Rig for learning


#1

Used this guy to get me to learn Mgear.
I think my only roadblock is the mouth(pinched corners) so far.


#2

Cool! Did you get him into the engine successfully now?


#3

Actually no, I never did. the foot kept breaking. Decided to go with arnold(really slow).


#4

@Ross_Daniel

Played with a version of your rig not too long ago and it looked pretty solid.

A couple of questions for you:

  • what is breaking about the foot?
  • what leg and foot components are you using? leg_2jnt_01 and foot_bk_01?
  • what does your export set look like? Is there more than the binds and mesh in the set?
  • What engine are you trying to export to? Unreal, Unity, or custom?
  • Assuming you’re exporting FBX does it look broken in FBX Preview?

#5

Not sure yet but It has something to do with mgear exporting to unreal.

I used biped template so whichever one is on the biped template.

When exporting to unreal I tried many different things like baking animation to Geo(fbx). I tried game exporter etc. So everything was pretty much narrowed down to the mesh and the skeleton.

Unreal

Not sure what is FBX preview. I probably never used it.


#6

Preview, Review, samething no? FBX Review super helpful in seeing if the content being export from Maya looks the same as what you have in Maya. If you’re seeing issues in FBX Review, it’s most likely a rig issue.

I’m going to assume that you’re working with the latest version of Unreal

You shouldn’t need to bake to geo unless you’re using custom deformers. oh, do you have any custom nodes like ngskin or shapes on your mesh?

Have you tried deleting the right leg of the guide, duplicate symmetry of the left leg, and then re-building the rig?


#7

You can download the rig here to try it out yourself.


#8

Hi,

I had some beaks happening when I export my rigs from fbx version 2017 and 2018. Change the version to 2014/2015 I never got any breaks.

The same thing happened with your statesman rig. I also checked it with a animation and it got exported properly.

Hope this might help


#9

@niteshms04 any idea if that is a known bug in FBX 2017/2018?

Thanks


#10

Nope sorry, I never actually checked. @Miquel