Home Youtube GitHub

Studio Library error read only node with Mgear rig


#1

Hi There

I am having a problem with studio library and mgear, when our animator wants to save out a anim clip when he selects all the controls and tries to save out the clip. He receives an error stating that a “read only node cant be changed”. Has anyone ever had this happen before any help would be appreciated.

The rig is also referenced in the scene and its just the standard biped template rig.

Greetings

PS. We also tested now that if you import the rig into a clean scene animate it and try save out a Studio library clip then it works and also referencing it into a clean scene ,animating the rig and saving out a clip then it still works. Its only in the scene he has animated in that this seems to be occurring.

We also tried using ATOM to take the anim from the scene and place the anim on a fresh rig in a new scene then it still gives the error. So basically tested all that stuff and still dont really what the problem could be


#2

Hi @Ruan_Myburgh

What version of Studio Liv are you on please?

Thanks


#3

We are using version 2.2.6


#4

Can you please update to https://github.com/krathjen/studiolibrary/releases/tag/2.3.4 and let me know if this still happens. If it does we might need a rig file. Check on your side as well if you haven’t set nodes to a
lockNode state. You can try to select all your rig nodes and run the following to know if you have some nodes that are really locked

from maya import cmds

for node in cmds.ls(selection=True):
    if cmds.lockNode(node, query=True, lock=True):
        print "{} is a locked node".format(node)

#5

I’ll try this asap and let you know the result, thank you


#6

Okay thank you very much Jerome that seems to have worked, should hit myself on the head for not having thought of just using a more recent version of Studio Lib


#7

So for the explanation it’s probably Maya’s Proxy Attributes which wasn’t supported by studio lib before version 2.3.3.


#8

And unless you are on Maya 2019, you might want to just avoid using Proxy Attrs completely: Proxy Attributes are broken when animation layers are deleted

We ran into problems with rigs breaking, without even using animation layers, as that topic suggests. This isn’t related to your errors, but just a warning.


#9

This happened to us when we referenced any rig. If we import the rig into the scene and then used studio lib it worked properly.