Website Youtube GitHub

mGear Framework Forum

animPicker not loading - Maya 2019 / Win 10

Hi!

I’m uploading our rigs to mGear 3.4, and I was looking into updating our synoptic when I decided to give the new animPicker a try. However, with a fresh install of mGear 3.4, I am not able to load the provided .pkr files. Just in case this was related to my character, I have just a default Biped built, but the error persists. This is the log:

# Traceback (most recent call last):
#   File "C:/Users/18182/Documents/maya/2019/scripts\mgear\anim_picker\widgets\basic.py", line 99, in index_change_event
#     self.callback(index=index, *self.args, **self.kwargs)
#   File "C:/Users/18182/Documents/maya/2019/scripts\mgear\anim_picker\gui.py", line 1108, in selector_change_event
#     self.load_character()
#   File "C:/Users/18182/Documents/maya/2019/scripts\mgear\anim_picker\gui.py", line 1279, in load_character
#     path = picker_data.get("snapshot", None)
# AttributeError: 'list' object has no attribute 'get'

The PICKER_DATA node’s fields look like this:
picker

Do you have any clue on what might be going on?

Thanks a lot!

I will try today with Maya 2019

btw: which anim_picker are you trying biped or biped_simple?

Hi, Miquel! It seems it happens with both files. I’ll be able to try it in Maya 2019 OSX in a couple of hours. I’ll let you know how it goes. Thanks for looking into it!

1 Like

Hi @iker.mozos

I couldn’t try with Maya 2019 my licensed for 2019 expired last month :frowning: But It has issues to load in 2020 :scream: :scream: :scream: :scream: :scream:
This is the errro for the biped_simple. pkr

# TypeError: # 'PySide2.QtCore.QPointF.__mul__' called with wrong argument types:
#   PySide2.QtCore.QPointF.__mul__(QTransform)
# Supported signatures:
  PySide2.QtCore.QPointF.__mul__(float)

The error was affecting also CentOS. here is the ticket


I will fix this tomorrow at the office. But not sure if will fix your issue. :stuck_out_tongue: lets try!!

Just tried in Maya 2019 OSX, and I get the same error than in Windows. I also tried to load it in Maya 2020 Windows 10, and got the issue you mention in your message. Hopefully solving it will get rid of my issue.

Thanks a lot, Miquel!

1 Like

I think it is fixed https://github.com/mgear-dev/anim_picker/commit/5b7bd23c12de3d43cd9ce8f194a866ea133563ea

The fix is in this lines
image

@iker.mozos Can you try to cherry-pick the commit or edit by hand to see if also fix your issue?

thanks!

1 Like

@Miquel It does not fix the issue :frowning:

Reading further, animPicker says the tool requires PyQT or PySide, and I do not have those libraries installed apart from what comes with mGear and Maya. Just in case, I downloaded PySide for Python 2.7 and copied those libraries inside Maya’s Python; PySide2 was already there, but I copied PySide as well.

If anyone reading this could confirm that they have the picker working in Maya 2019 (Win/OSX) it would be great. Because then it means the error is, somehow, on my side :smiley:

PySide2 is installed with Maya. You should not install Pyside.

Good news, everyone! Following @Jerome’s suggestion to install Updates 1 and 2 in Maya 2019 to solve a crash-related issue when building in 3.4.0 solved the animPicker problem. Now I’m able to use it as described in the documentation. Hooray!

2 Likes