Website Youtube GitHub

"arm_L0_fk2_ctl" and "leg_L0_fk2_ctl" do not work


#1

Goodmorning.

After creating a “Biped Template”, I select “armUI_L0_ctl” and switch to FK mode (set 0 in the FK/IK Blend attribute).
Now, when I try to rotate the “arm_L0_fk2_ctl”, the joints of the hand remain blocked, don’t follow the rotations.

The same problem occurs with the “leg_L0_fk2_ctl”.

Is a bug?

I have the mGear 3.0.3 version on Maya 2019.


#2

Ups… the problem was that I had activated “Preserve Children” in the Rotate tool settings.

I apologize for the useless message. :frowning:


#3

Oh man, I’ve done that so many times too! :rofl:

I think it is safe to say that this option is often used when placing guides, and RARELY (and dangerously) used in rigs. Here is how you can include the command to disable preserve children in a post script and avoid this very common mistake.

Put this Python in a post script and when you build the rig, it will turn it OFF!

import maya.mel as mel
mel.eval('setTRSPreserveChildPosition false;')

#4

Thanks for the support.