Home Website Youtube GitHub

Cannot use rig1 to drive root_drv

We seem to have some troubles use the mGear.
After export from MetaHumans to Maya.
We tried to add controller to the skeleton.
We tried mGear_Master and mGear beta4.0 with maya 2019-2022.
Following the steps,everything is working until last step.
When we click build, we got rig1 successfully.
But we can’t ues rig1 to drive root_drv. And we couldn’t make our actor model move.
Maybe we missed a step. Can you tell what went wrong?
Hope to hear from you soon. It’s very important for our project.
Thanks in advance.

您好,不知道您是否观看了mGear 4.0.0 Beta 1这个帖子当中的视频。
根据您的截图

来判断区别在于Joints Slider Naming和MetaHuman的关节名称不一致,您可以更改为小写“l”或者“r”尝试一下。
视频当中是较旧版本的NamingRule,您使用的是经过增强之后的版本。
记录在这里:
Shifter: naming rule side for joints and Ctl separated option #19
Shifter: Naming rule support for index padding #16

玩的愉快 :grinning:

We uninstalled mGear Master. Then we tried mGear 4.0.0 Beta 1. It’s working now. Problem solved! Thanks a lot!!!
By the way, what’s the difference between Master and 4.0.0 Bate?

1 Like

From my understanding, Master is the active development git repository where things are being worked on now. And the 4.0.0 Beta is a packaged-up release, intended to be downloaded and used. (Or at least tested carefully, since it is Beta.)