Home Website Youtube GitHub

mGear 4.0.0 Beta 1

mGear 4.0 Beta 1 is available. Python 3 compatible and a new way to attach mGear rigs to existing joints.
Please report any bug :wink:

7 Likes

Im burning to test it!
I hope it does work with my old files.

Old files does open fine. No issues so far!

No drag n drop install? :frowning:

Hi Ross, it’s beta right now. If you aren’t comfortable installing it, it might be best to wait until it is bug-tested for now. Definitely don’t quickly throw this into production without testing first.

2 Likes

Hi, quick heads up-

I downloaded the mGear 4.0.0 beta link. When I went to extract the zip file- Norton was flagging a bunch of the .mll files as having “WS.Reputation.1” attached to them.

But when I ran a virus scan on the zip file itself, it didn’t pickup any virus. Anyone else having this issue?

*edit: I didn’t have this issue with mGear 3.7.11

Hi @JimBhak Thanks for the heads up. I use AVG Antivirus and it doesn’t detect anything.
Do you know if is flagging any specific file?

After a little google search, I found this article (a little old) but I think explanatory Norton have got it very wrong with WS.Reputation.1 detection | My Life

Thanks for the reply, Miquel.
Hm, I tried extracting again today, and no errors popped up. Guess they have been whitelisted now. I don’t remember all the files that were flagged, but I think “twistspline.mll” was one of them. But it didn’t cause a warning when I extracted just now. Anyway, thanks for your help!

1 Like

Thanks for the beta. Can this version 4.0.0 work in maya 2020 in windows 7?

I think I am missing something – when I try to run the guide manager:

\Maya2022\Python37\lib\site-packages\shiboken2\files.dir\shibokensupport_feature_.py line 142: No module named 'Qt

Hi @polyoptics
That is is a bug, and it is already fixed. :slight_smile:

Beta 2 should be available soon

1 Like

Hah of course, awesome!! Thx Miquel

How do we install the Beta?

Hi @umibozu the same way you install previous versions. Where are you stuck?

http://www.mgear-framework.com/mgear_dist/quickStart.html

Oh sorry let me try that. I had the latest version downloaded prior to this Beta download and it used a drag and drop script!

Thanks,
Matt

I copied the contents over,but when I launch Maya it does not show an MGear menu?

Copied what to where? If you’d like help, you need to include more info in your posts please.

I am sorry if I was unclear. I followed the instructions you sent and I copied the beta downloaded files to

C:\Users\Matt\Documents\maya\2023\modules