Website Youtube GitHub

mGear Framework Forum

Maya 2020 no open rig file

hello good friends I’m having a problem.

I was doing 2 rigs and from one moment to the next my file doesn’t open anymore
when trying to open the file with maya it just closes, there is no error message

and get edit file .ma and delete all lines that contain
“createNode##############################ctl_controlBuffer

I am using maya 2020 / 2020.1+mgear 3.4

What are you showing in the screenshot?

Where is “createNode##############################ctl_controlBuffer” appearing?

hi @chrislesage
edit the .ma file with sublime text and erase the lines that end _ctl_controlBuffer.
it’s the only way i can open my file

it seems that the shape data that I store “extract control” is the problem

I had already given up but was able to open my file with maya 2018 and I get these errors

for some reason it does not open with maya 2019.2 / 2020
it just doesn’t open I don’t have any error message it just closes the program

Hello,

I am also experiencing this. I save a file but I can’t open it anymore. It just closes Maya without loading.

I’m using 2020.1 and mGear 3.4.

What exactly will happen if I delete these lines?

Also does anyone have any idea why this is happening?

it is a strange error,

1: edit the Maya file with “sublime text”
and delete all the lines that start and end like this

“createNode ############################## ctl_controlBuffer”

With this you eliminate parts of the rigging but recover the geometry

2: you can try open on maya 2018 too