Website Youtube GitHub

mGear Framework Forum

Maya crashing Mgear viewport menu

Hi, I’m bulding a rig using mgear arms, I created and tested it, it worked as a charm, then started working in the rest of the rigg, and eventually when I wanted to try the ikfk snaps maya crashed as soon as i right clicked the root node of the arm with the viewport menu activated, no error message or anything, I can’t find any clue to solve the problem, any idea what can be happening? or an alternative way to acces the ikfk snaps from animpicker or something like that. Sorry but i can’t provide the rig due to nda. It’s my first time using Mgear, so I’m sorry if the solution is obvius

Hi, Jerome, I saw you changed my post to a private message, I Forgot to add that I’m using maya 2020.2

Sorry @jose_rodriguez did not mean to make it private. Was a mistake on my side. So the crashing is happening due to an internal command loop on Maya’s controller command. I tried to fix this on last release but this is still happening with certain controls and on the last fix I did I did a bad job at it because not only I did not cover all the crash cases but at the same time I broke the cascading child querying. Hopefully next month I will be able to fix this. What is weird is that you have that on the HOST ui controls. Maybe you can privately share your guides so that I can take a look on my last mGear version.

Thanks

2 Likes

Hi, jerome, I can send you a scene with just the controllers so you can check it yourself. But I can’t find a way to send you a private message (maybe i’m just blind and i don’t see the button)

Will send you a private message

1 Like

(As a new user, you may not be able to send private messages yet. I think that gets unlocked once you have a certain level of activity in the forums.)

Hello @jose_rodriguez

I opened your rig file send to me but I got confuse by opening it. So you are building parts of the rigs with mgear and other fully manually and you are changing names on controls as well. It was even a little bit weird because you are not updating the HOST attribute direction so selecting the host control from the IK control doesn’t work.

If you want to avoid the hard crash you can delete this node on your scene global_C0_ctl_tag16
That been said on your HOST control Ctrl_ArmsMaster the attributes that allows the ik/fk snap have the names of controls created when building the rig. As you changed your controls names this wont work, so you need to change the attribute as well so that it contains your controls names.

I know not everybody likes the names of controls on mGear and we do have a ticket on our GitHub about it to make it more “customizable”. Because there’s no build relationship yet between the rig components and the DagMenu if you change things you need to be conscious that it might break other tools behavior.

Hope this helps.

1 Like

Hi Jerome, It helped, it’s my first time using Mgear, and also I’m not the most experienced rigger out there (i just hit my first year working in the industry). I was unsure if the ikfk worked by name or not, I tried changing the name of the controllers before building the full rig and it worked or thats what i thought, maybe I missed changing the names of some critical nodes or something in the test I did. I think i tried deleting this global_C0_ctl_tag16 before and something crashed, or maybe I’m wrong. So the solution is to update the attibute. I will try to solve it tomorrow at the office and will let you know if i can solve it. Sorry for causing you trouble.

There’s no trouble at all @jose_rodriguez. Good luck

So, I have been checking it,aside from the host attribute not being updated with new names i had also deleted a controller that my animators didn’t find usefull (i should have just hided it). After trying to rebuild the missing one and changed the names in the host attribute, I got stuck at this points, not crashing anymore, but when trying to do the ikfk snap i get this error (anim_utils.py line 277: ‘NoneType’ object has no attribute ‘split’ ). At this point i think it would be faster to just re-build the arms from the beggining hahaha.

Hello @jose_rodriguez
There is more to it when changing the names of controls…
There are transform nodes inside the rig structure that allow calculating the snapping.

I should have mentioned sooner that it isn’t a good practice when using mGear on changing it’s rig hierarchies or name conventions or removing certain things. This just makes things harder not only for you but for us when trying to help you. I which I could tell you how to take your rig and make it compatible again with the snap but there are just to many changes applied to your rig scene. I would recommend building the arm rig and leaving it as it is without changing names a already test if everything behaves as it should.

Good luck

1 Like

Hi again Jerome, I will probably re-build the whole arms set-up as you suggested, a bit frustrating not to be able to fix it, but that’s what i get for not testing things properly before doing the final rig. Again, thank you for your help, can’t wait to learn more about mgear and don’t make this mistakes again.