Home Website Youtube GitHub

Maya Freezing my Mac

Im getting really frustrated with this, Maya has been working perfectly for years but over the last 3 weeks it has been completely freezing my Mac to the point where I need to hold the power button and turn it off. Im not doing any high-poly work, and it freezes randomly within 10 seconds - 5 minutes. I have repaired my driver etc on my MacBook and they’re all fine, and ive also installed 3 different versions of Maya but the problem persists. Is this happening for anyone else? Any solutions?

Hi @Buster

I’m on Mac, and I haven’t experienced this. (Maya definitely freezes a lot, but not regularly like this.) Some of my animators were experiencing freezing while animating (not just mGear rigs), and this fixed it, sometimes: https://twitter.com/chrislesage/status/1338314328743817217

What kind of work are you doing when it freezes? Is it related to specific rigs? Or just anything at all in Maya?

Can you think of anything that did change recently? Including MacOS updates? Did you install any new plugins in Maya?

How much RAM do you have? Are you running low on RAM or HD space? (Although I more suspect GPU issues.)

I also discovered a freezing issue last week. I had ngSkinTools layers on some geometry, and then I altered the topology of the geometry, but forgot to delete the ngSkinTools layers! When I went to save (or auto-save), Maya would freeze. I had to delete that out-of-date ngSkin layers on that geo, before I could save again, then it was fine.

Hi, thank you for your reply!

I didn’t actually realise this was a group dedicated for mGear rigs, but thank you for giving me some help.

I have only been doing basic poly modelling, and it’s only at around 40,000 poly count, nothing too strenuous. I have worked with much higher before and it’s been fine. I have tried using different files but the same freezing still occurs.

I was using Maya 2020 until a few weeks ago, it froze a few times so that prompted me to install the newest version, but the same thing was happening. I don’t remember specifically downloading an update just before this, but since then I have continued to keep my Mac up to date.

I have no new plugins for Maya, and my Mac has 8GB of RAM. The hard drive is close to being full, but there’s definitely enough space to make some of the tiny changes that I’m trying to make. I’ll clear some extra space ASAP and see if that resolves the issue.

I’ve been using Maya for over a year on this Mac and have had no problems previously, it’s only just started in the past few weeks. I’ve only recently finished my first year at University so it’s lucky that this has just started now rather than while I was completing assignments!

Also I’d just like to add that I have tried to contact Autodesk about this, but it says that I do not have permission to contact them, and I need to contact my administrators. I thibk this is due to having a student license :confused:

You might want to try deleting your prefs too.

With Maya closed, backup your prefs folder somewhere else, and then delete the folder.

If you reinstall Maya, unless you delete those preferences, they will stay with your new installation. And if you have something corrupt in those prefs, it might be causing it. (Maybe not, but it’s worth a test.)

:sweat_smile: haha no worries