Website Youtube GitHub

Mgear 3.2 Mac BiPed template failing


#1

Hey Guys,

Just trying to get 3.2 working on mac. I’ve installed it correctly as per video.

  • copy release folder to location
  • link .env file to location

It seems to be able to build simple arms joints properly, but when i select the biped template it gets stuck building it at the spine joint.

Attaheched a few images for refernece. Any help would be appreaciated.

Using maya 2019, mgear 3.2.0

thanks,
tom


#2

And this is the mgear log


#3

Is it a fresh biped template, or did you make any changes at all?

Do you have only one guide in the scene? If you have more than one guide, I would suspect a possible name clash.

Can you see if it is this bug, where sometimes guides get named with a double L0_L0 or R0_R0 or C0_C0?

Also, for error messages, it’s better just to paste the text, instead of a screenshot of the text. It makes it easier to copy/paste stuff and go searching into files.


#4

Also, what do you have selected when you build? You should select the “guide” node at the top, right?

EDIT: ALSO, I don’t think the MacOS solvers have been officially released for Maya 2019 yet.

They can be downloaded here, but I don’t think they are in the release yet. Spider-Verse mGear Rig, and Mac Installation

Did you install those solvers? I’m not sure if that would cause or fix the errors you’re seeing, but you’ll need those.


#5

Hey Chris,
Thanks for helping me out with this. Yeah its a fresh template, no changes made.

I just go mGear > Shifter > Guide template samples > Biped on a new scene and i get the error.

I suspect those solvers might the case, It might sound silly, but how do i go about installing them? No idea where to put them.

thanks,
tom


#6

You can follow this


#7

Hey Jerome,

Appreciate the reply. I’ve placed them there, but still no luck.

Also i tried building a simple arm joint. Turns out it doesnt build fine, i must have overlooked it :confused:

but here is the script editor dump from a clean scene.

GEAR version : 3.2.0

= SHIFTER RIG SYSTEM ==============================================

= GUIDE VALIDATION ==============================================
Checking guide
Get options
Get controllers
Get components
arm_C0 (arm_2jnt_02)
Find recursive in [ 0:00:00.039699 ]
Get parenting for: arm_C0
Guide loaded from hierarchy in [ 0:00:00.040673 ]

= BUILDING RIG ==============================================
Initial Hierarchy
Init : arm_C0 (arm_2jnt_02)
Objects : arm_C0 (arm_2jnt_02)

Traceback (most recent call last):

File “/Users/Elson/Library/Preferences/Autodesk/maya/2019/modules/release/scripts/mgear/shifter/guide_manager.py”, line 62, in build_from_selection

rg.buildFromSelection()

File “/Users/Elson/Library/Preferences/Autodesk/maya/2019/modules/release/scripts/mgear/shifter/init.py”, line 184, in buildFromSelection

self.build()

File “/Users/Elson/Library/Preferences/Autodesk/maya/2019/modules/release/scripts/mgear/shifter/init.py”, line 210, in build

self.processComponents()

File “/Users/Elson/Library/Preferences/Autodesk/maya/2019/modules/release/scripts/mgear/shifter/init.py”, line 388, in processComponents

comp.stepMethodsi

File “/Users/Elson/Library/Preferences/Autodesk/maya/2019/modules/release/scripts/mgear/shifter/component/init.py”, line 119, in step_00

self.addObjects()

File “/Users/Elson/Library/Preferences/Autodesk/maya/2019/modules/release/scripts/mgear/shifter_classic_components/arm_2jnt_02/init.py”, line 464, in addObjects

self.getName(“visalRef”), [self.upv_ctl, self.mid_ctl])

File “/Users/Elson/Library/Preferences/Autodesk/maya/2019/modules/release/scripts/mgear/core/icon.py”, line 1022, in connection_display_curve

crv = curve.addCnsCurve(centers[0], name, centers, degree)

File “/Users/Elson/Library/Preferences/Autodesk/maya/2019/modules/release/scripts/mgear/core/curve.py”, line 46, in addCnsCurve

applyop.gear_curvecns_op(node, centers)

File “/Users/Elson/Library/Preferences/Autodesk/maya/2019/modules/release/scripts/mgear/core/applyop.py”, line 369, in gear_curvecns_op

node = pm.deformer(type=“mgear_curveCns”)[0]

File “/Applications/Autodesk/maya2019/Maya.app/Contents/Frameworks/Python.framework/Versions/Current/lib/python2.7/site-packages/pymel/core/animation.py”, line 50, in deformer

return map(_general.PyNode, cmds.deformer(*args, **kwargs))

File “/Applications/Autodesk/maya2019/Maya.app/Contents/Frameworks/Python.framework/Versions/Current/lib/python2.7/site-packages/pymel/internal/pmcmds.py”, line 134, in deformer_wrapped

res = new_cmd(*new_args, **new_kwargs)

RuntimeError: Unable to create/find dependency node.

appreaciate all the help :smiley:


#8

Can you please run this on the script editor (python) and see if it works please?

import pymel.core as pm
node = pm.deformer(type="mgear_curveCns")[0]

#9

hey Jerome,

I get this error when i run the command.

Error: RuntimeError: file /Applications/Autodesk/maya2019/Maya.app/Contents/Frameworks/Python.framework/Versions/Current/lib/python2.7/site-packages/pymel/internal/pmcmds.py line 134: Unable to create/find dependency node.


#10

also this is the start up log on a fresh scene.

file -f -new;
// untitled //
commandPort -securityWarning -name commandportDefault;
onSetCurrentLayout “Maya Classic”;

pymel.core : Updating pymel with pre-loaded plugins: GPUBuiltInDeformer, cacheEvaluator, deformerEvaluator, renderSetup

Error: You need the mgear_solvers plugin!

Warning: RBF Manager couldn’t found any valid RBF solver.

// Warning: file: /Users/Elson/Library/Preferences/Autodesk/maya/2019/prefs/filePathEditorRegistryPrefs.mel line 4: filePathEditor: Attribute ‘aiImage.filename’ is invalid or is not designated ‘usedAsFilename’. //
// Warning: file: /Users/Elson/Library/Preferences/Autodesk/maya/2019/prefs/filePathEditorRegistryPrefs.mel line 5: filePathEditor: Attribute ‘aiPhotometricLight.aiFilename’ is invalid or is not designated ‘usedAsFilename’. //
// Warning: file: /Users/Elson/Library/Preferences/Autodesk/maya/2019/prefs/filePathEditorRegistryPrefs.mel line 6: filePathEditor: Attribute ‘aiStandIn.dso’ is invalid or is not designated ‘usedAsFilename’. //
// Warning: file: /Users/Elson/Library/Preferences/Autodesk/maya/2019/prefs/filePathEditorRegistryPrefs.mel line 7: filePathEditor: Attribute ‘aiVolume.filename’ is invalid or is not designated ‘usedAsFilename’. //
// AbcExport v1.0 using Alembic 1.7.5 (built Feb 7 2018 13:51:52) //
evalDeferred “shaderBallRendererMenuUpdate”;
// Warning: line 1: filePathEditor: Attribute ‘aiStandIn.dso’ and label ‘Standin’ have been saved already. //
// Warning: line 1: filePathEditor: Attribute ‘aiVolume.filename’ and label ‘VDB’ have been saved already. //
// Warning: line 1: filePathEditor: Attribute ‘aiImage.filename’ and label ‘Image’ have been saved already. //
// Warning: line 1: filePathEditor: Attribute ‘aiPhotometricLight.aiFilename’ and label ‘IES’ have been saved already. //
import arnold
// Successfully imported python module ‘arnold’ //
import mtoa
// Successfully imported python module ‘mtoa’ //
import mtoa.cmds.registerArnoldRenderer;mtoa.cmds.registerArnoldRenderer.registerArnoldRenderer()
// Successfully registered renderer ‘arnold’ //
updateRenderOverride;
// Warning: file: /Applications/Autodesk/maya2019/Maya.app/Contents/scripts/startup/autoLoadPlugin.mel line 35: Loading plug-in “mtoa” has resulted in changes to the scene that may need to be saved. //
// AbcImport v1.0 using Alembic 1.7.5 (built Feb 7 2018 13:51:52) //
updateRendererUI;
updateRendererUI;


#11

Yeah so the solvers aren’t loading correctly. Hmm…

Can you please paste the mGear lines from your Maya.env just to double check for any problems?

There is a chance either there is a problem with your installation, or those compiled solvers are not working properly on your system. I don’t have Maya 2019 installed so I can’t test for you, but if we don’t figure this out today, I’ll go and install it and test them on my side.

(Meta: When you post code, you can put it between 3 backticks, or in a code block and it will format more nicely.)


#12

Oh, I think I might know.

I believe the plugins should be inside a directory called plug-ins. In your screenshot you put them directly under x64

image


#13

Chris! Legend! works now, thanks so much for helping me out. “Plug-ins” folder was needed. Thanks Jerome as well.

woooo