Home Website Youtube GitHub

Mgear is not displayed in maya2022

hello
I need your help
Maya’s plug-in manager display is loaded but you can’t see the interface in Maya

1 Like

Did you install PyMEL when you installed Maya 2022?

1 Like

Python3 is installed when Maya is installed

PyMEL

PyMEL is an option you must choose when you install Maya. (Or maybe you can install it after.) In Maya2022 it became an option.

Hi, I’ve got the same issue, I’ve installed pymel 3 yet it still does not appear

I had this problem in Win 10, Maya 2022.1 when installing to a custom location on a different drive.
I fixed it by installing to the default location using the drag n drop installer.

This is just a hunch, but I believe it may be caused by the newer security features which prevent code from running from random locations. Normally when trying to run a plugin from a new location I get a security prompt, but in this case when using the automatic installer set to a custom location I didn’t get that security dialog, leading me to think that the module may have been blocked by maya.

Edit: another thing that I did before getting it to work was uninstalling from the drag n drop dialog. Maybe the problem wasn’t security related and that’s what fixed it.

1 Like

just to confirm, have you installed pymel for python3 ?

Correct me if I’m wrong, but I believe if OP didn’t have pymel for py3 installed then some red error message should be displayed by maya during the installation process, no?
For me, when I had that problem, there was no error (and I did have pymel installed).

I just uninstalled and reinstalled mgear just to check if I would replicate the error.

  1. Uninstall (from the drag n drop script)
  2. Restart maya
  3. Install to custom location
  4. Restart maya

And again, maya couldn’t load the module.
After that, installing to the default location fixed it.

Maybe there’s an bug in the way the maya.env file is edited? I’ll try installing it manually to a custom location without the script

Edit
I’ve narrowed down the bug to line 332 of the drag n drop installer.

I changed it from this
self.pre_append_line(env_file, ‘{0}="{1}"’
To
self.pre_append_line(env_file, ‘{0}={1}’

For some reason VAR_NAME=“PATH” doesn’t work, but VAR_NAME=PATH works.
I found it odd that when the env file was clean and you were installing to a custom location then it worked, but if the env file was dirty then it didn’t. Then I saw that in the two branches of the function, the way the file was being edited was different.
In the if not result branch, the env file is modified without the quotes.
In the else branch, the env file (MGEAR_MODULE_PATH) is modified with the quotation marks, which for some reason in my system breaks it.

1 Like

I’ve got the same problem. pymel for python 3 is installed but the mgear menu won’t show up in Maya 2022.
Running “import mgear” gives no error messages.

Hi ! I have got the same issue and It seems that you must select the correct path when you install mgear. For me, the drag n drop want to install in maya/modules where it should install in maya/2022/modules

After change it, the menu appears magically

2 Likes

For me nothing helped